iT邦幫忙

0

SWITCH 管理設定?

redcash777 7 年前6447 瀏覽

先跪謝各位大大.小弟家貧目前念大2沒錢補習~有很多不會的想問
如下
interface FastEthernet0/2
switchport trunk allowed vlan 300-301
switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
switchport access vlan 301
switchport trunk allowed vlan 301-1001
switchport mode access

想請問這一行如何刪除switchport trunk allowed vlan 301-1001?
我改來改去都刪不掉....><
1.要下甚麼指令?
2.我設了a台-switch管理的vlan300(192.168.10.2 255.255.255.0)gateway192.168.10.1
b台_switch管理的vlan300(192.168.10.3 255.255.255.0)gateway192.168.10.1

請問 a台如新增一個VLAN 301..fa04.B台也新增一個vlan301.fa04
要他們相通是否interface FastEthernet0/2(假設是原a.b台管理的界面vlan300)都新增如下:就可互通是嗎?
switchport trunk allowed vlan 300-301
switchport mode trunk
3.trunk一般都是設在管理vlan那嗎?

2 個回答

14
wellack
iT邦新手 5 級 ‧ 7 年前
最佳解答

1:Cisco的Switch??如果是可以試試看下方的步驟:
Switch(config)# interface fa0/4
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk allowed vlan remove 301-1001
Switch(config-if)# end
Switch(config-if)# switchport mode access
Switch(config-if)# end
Switch# show interface fa0/4 switchport allowed-vlan

2:
Switch# configure terminal
Switch(config)# interface fa0/2
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk encapsulation isl 或 switchport trunk encapsulation dotlq
Switch(config-if)# end
Switch# show interface fa0/2 switchport
Switch# copy running-config startup-config

印象中Trunk port不屬於任何VLAN唷

4.因為很久沒設定cisco switch,所以不確定有沒有錯誤的地方,提供給您參考囉!

2
ansonchen
iT邦新手 1 級 ‧ 7 年前

A B 兩台都要有vlan id資料
A台 vlan 300-350
B台 vlan 400-500

A switch

int fa 0/2
sw trunk enc dot1q
sw mo trunk
sw tr all vlan 300 - 500


B switch

int fa 0/2
sw trunk enc dot1q
sw mo trunk
sw tr all vlan 300 - 500

此時這2台 switch vlan即可互通

刪除步驟可能錯了
fa 0/4 現在先把他 no 掉
interface FastEthernet0/4
no switchport access vlan 301
no switchport mode access
sw mo trunk
no switchport trunk allowed vlan 301-1001
no sw mo trunk

若是L3 直接 no switch -> switch

我要發表回答

立即登入回答