iT邦幫忙

0

Exchange2010擋信問題,完全沒退信,不知道信件寄去哪了?

大家好 小弟又有問題需要麻煩大家了

小弟的公司有架AD、Exchange2010 我以前只有"翻書"看過AD的粗淺概念

Exchange則完全不熟悉 也不曾管理過Mail Server 公司現在遇到一個問題 我一直還解決不了...

公司有一個委外維護的網頁 有寄電子報的功能 透過同事登入系統 可以管理電子報內容、名單...等操作

目前問題是這樣 公司的信箱都收不到此系統寄出的電子報 此系統是使用虛擬的Mail寄的

我從Exchange伺服器上關閉所有反垃圾郵件 仍然收不到電子報 垃圾郵件中也沒有 也沒退信

也試過將對方的收發信伺服器IP加入至允許清單 但仍然收不到電子報 垃圾郵件中也沒有 也沒退信

我曾問過我以前的資訊廠商 他表示Exchange本身預設是不會開啟反垃圾郵件的功能的

必須透過指令才能開啟此功能 依我們公司狀況應該是後來才開始此功能的

開啟後 就算將其反垃圾郵件的設定都關閉 但依然會擋掉相當多的郵件

不知道是否可以將反垃圾郵件的功能完成刪除?

另外 我也試過登入防火牆Fortina 110C看過紀錄 UTM->郵件過濾都是關閉的

從紀錄中伺服也查不到從對方發信伺服器IP的記錄...

現在實在是不知道該怎麼處理 下星期這電子報就要實際上機使用了

麻煩各位高手請協助我...

謝謝

所以到底是誰寄給誰?Exchange Server 是哪一台?
6
ctipde
iT邦高手 1 級 ‧ 2012-08-27 17:11:52
最佳解答

1.先設定電子報寄送到免費郵件網址(如gmail,hotmail),測試電子報的寄送功能是ok的。
2.查詢Exchange的log記錄是否有收到此電子報的資訊路徑如下:Exchange2007(Exchange Server\TransportRoles\Logs\ProtocolLog\SmtpReceive)
3.問一下委外公司是否電子報寄送記錄,查看看是卡在哪一個關卡。

4
u8526425
iT邦大師 1 級 ‧ 2012-08-27 11:10:49

查LOG
發送端Mail log
收件端Mail log
可以知道有沒有發 有沒有收 沒收到是跑哪去

收件端Anti-SPAM log
如果有被擋, 也會知道被擋的理由是什麼

4
msit
iT邦高手 1 級 ‧ 2012-08-27 11:19:17

在SMTP屬性中
啟動 在傳輸伺服器上使用外部DNS查詢設定
因為好像是部分IPv6查詢,查到Hinet會異常,沒有傳回IPv4的值,所以信件消失。啟用後,看看可不可以。

4
willhomwtw
iT邦新手 1 級 ‧ 2012-08-27 11:27:05

1.確認一下查詢的 log 紀錄是不是正確;先比照查詢看看其他的郵件,是不是可以查的到
2.確認一下外網 dns 上的 mx 紀錄..看看是不是跟你 exchange 上的對外 ip 一樣
3.架構上確認一下,exchage 前端是不是還有設備;例如 spam server 之類.或是防毒牆之類的設備

4
taleships
iT邦新手 4 級 ‧ 2012-08-28 13:37:47

victor7556提到:
公司的信箱都收不到此系統寄出的電子報 此系統是使用虛擬的Mail寄的

這句看不太懂...虛擬MAIL指的是?

Exchange 2010 可以到工具箱內去察看郵件路由、郵件柱列、追蹤郵件功能等等
2010已經大幅改善疑難排解功能囉,先了解電子報寄送的路由可能對問題比較有幫助
ANTI SPAM應該是在HT上啟動的吧...

4
jerry6719
iT邦新手 3 級 ‧ 2012-08-28 14:43:12

首先應該是找mail的出去紀錄,找不到的話換 Spam mail 尋找,在找不到 就是防火牆找,通常都有進出紀錄才對。

4
deanspp
iT邦新手 5 級 ‧ 2012-08-28 17:42:07

Dear Victor

Email server 的架構應該不複雜,送你一句話,凡走過必留痕跡。

上面幾位大大的方法應該可以解決你的問題。

看你上面的問題,比較有可能是你的虛擬mail server 的問題。

信是不是根本沒寄出呢?很好奇!如果解決了一定要跟我們說喔!

廠商的虛擬郵件伺服器應該是有寄出
我的hotmail、Gmail都有收到
唯獨公司的Mail都收不到說...

4
solomonqoo
iT邦新手 4 級 ‧ 2012-08-29 16:07:30

請問你有使用edge server嗎?
過濾與垃圾郵件的功能主要是在這一台上設定的,
很有可能是兩個問題:
1、你的SCL分級等級的問題
2、Edge server上會進行”附件過濾”的動作,建議採取將其disable的方式來解決,
(停用該功能後,必需將MSExchangeTransport服務重新啟動,才會生效)。
disable-transportagent -identity "attachment filtering agent"

當然也可能是其他的問題,exchange 2010真的搞的太複雜了!

我要發表回答

立即登入回答