iT邦幫忙

0

CentOS 6裝apache2.2.34 + php 5.6.32

不好意思,這個問題有點突然。

這個部份是為了因應資安報告修正建議的套件版本

目前裝的狀況是:

apache 2.2.29升2.2.34可以用make安裝,但是編譯安裝前需要把舊的httpd刪除 會連帶刪除php因此安裝後要重新安裝php

當安裝完httpd 2.2.34要yum install php時都會強制把httpd的版本降到2.2.15 因此嘗試php也利用make的方式去安裝。

但php編譯安裝在做到make install時都會提示:
make: *** [install-modules] Error 1錯誤 無法進行安裝

目前在這個地方卡關了幾天,想要請教大家,目前在Centos 6當中,
有比apache2.2.34 + php 5.6.32 版本還要更高且能穩定安裝的組合嗎?

看更多先前的討論...收起先前的討論...
weiclin iT邦高手 4 級 ‧ 2018-05-11 19:44:39 檢舉
你八成少了什麼套件所以編譯失敗了, 編譯的錯誤訊息最後一頁貼上來看看
snameless iT邦新手 5 級 ‧ 2018-05-14 13:58:15 檢舉
[root@localhost php-5.6.36]# make install
Installing shared extensions: /usr/local/php5636 --with-libdir=lib64 --enable-fpm --with-fpm-user=php-fpm --with-fpm-group=www --enable-mysqlnd --with-mysql=mysqlnd --with-mysqli=mysqlnd --with-pdo-mysql=mysqlnd --enable-opcache --enable-pcntl --enable-mbstring --enable-soap --enable-zip --enable-calendar --enable-bcmath --enable-exif --enable-ftp --enable-intl --with-openssl --with-zlib --with-curl --with-gd --with-zlib-dir=/usr/lib --with-png-dir=/usr/lib --with-jpeg-dir=/usr/lib --with-freetype-dir=/usr/lib --with-gettext --with-mhash --with-ldap --with-apxs2=/usr/local/httpd/bin/apxs/lib/php/extensions/no-debug-non-zts-20131226/
cp: unrecognized option '--with-apxs2=/usr/local/httpd/bin/apxs/lib/php/extensions/no-debug-non-zts-20131226/#INST@98588#'
Try `cp --help' for more information.
make: *** [install-modules] Error 1
ayu iT邦好手 6 級 ‧ 2018-05-20 03:48:01 檢舉
如果OS是64bit版, 有考慮過XAMPP嗎?
snameless iT邦新手 5 級 ‧ 2018-05-21 11:01:12 檢舉
還沒想到過這個,我會再去研究下XAMPP,感謝!

1 個回答

0
炎之虛空
iT邦高手 3 級 ‧ 2018-05-13 12:34:29
最佳解答

直接透過 remi 方式不就好了?

rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY*
rpm -Uvh http://rpms.remirepo.net/enterprise/remi-release-6.rpm
yum -y install yum-utils
yum -y update
yum-config-manager --enable remi-php56
yum -y install php
snameless iT邦新手 5 級 ‧ 2018-05-14 13:03:06 檢舉

不好意思,現在才看到。
這個方法剛剛試過了,還是會降到httpd的版本。

我要發表回答

立即登入回答