iT邦幫忙

0

ubunt18.04 安裝tensorflow-gpu問題

各位大大你好,目前正在架設tensorflow運算環境

架設環境如下:
作業系統:ubuntu 18.04
顯示卡:Nvidia RTX 2080 Ti
CUDA版本:10.0
cuDNN版本:7.3.0
tensorflow版本:1.11.0

安裝完tensorflow後,匯入套件會報錯,error如下:
ImportError: libcublas.so.9.0: cannot open shared object file: No such file or directory

有搜尋過別人的error log
主要都是CUDA版本問題,但嘗試過安裝CUDA9.2,會出現不支援設備,無法安裝
另外是 找不到 libcubas的問題,也嘗試過把libcublas.so.9.0導到libcublas.so.10.0

但還是無法解決問題,想問一下有沒有大大有在這樣的環境中架設過tensorflow,麻煩指點一下謝謝!

froce iT邦大師 5 級 ‧ 2018-11-27 13:32:35 檢舉
沒錢買顯卡,等人贊助。(逃

幾個解決方案供參考。
1.降級 Ubuntu到16.04

2.自行編譯 tensorflow:
https://medium.com/@vitali.usau/install-cuda-10-0-cudnn-7-3-and-build-tensorflow-gpu-from-source-on-ubuntu-18-04-3daf720b83fe

3.docker:
https://www.tensorflow.org/install/docker
yanwu0105 iT邦新手 5 級 ‧ 2018-11-27 13:45:23 檢舉
大大您好
最初試過16.04版本,但好像因為顯卡關係一直安裝不起來,所以才改用18.04

感謝提供第二種方法,我試試看 謝謝
0
henry658
iT邦新手 5 級 ‧ 2018-11-28 23:05:37

hi 目前剛好有這個問題 第二個自行編譯可以請您說明的清楚一點嗎? 謝謝
另想請問 pip安裝tensorflow跟bazel安裝有什麼差異嗎?

yanwu0105 iT邦新手 5 級 ‧ 2018-11-29 09:38:08 檢舉

自行編譯就是到tensorflow官網上有教怎麼安裝
https://www.tensorflow.org/install/source
方法就是利用bazel編譯tensorflow的檔案再安裝

henry658 iT邦新手 5 級 ‧ 2018-11-29 15:20:07 檢舉

對那自行編譯有什麼好處 能讓我不選擇pip安裝呢

yanwu0105 iT邦新手 5 級 ‧ 2018-11-29 16:22:02 檢舉

CUDA-10.0 現在無法用pip安裝tensorflow

0
shift093
iT邦見習生 0 級 ‧ 2019-01-03 04:02:14

我成功的環境
OS:Ubuntu 16.04 and 18.04
GPU:2080ti * (1-8)
Driver:410.78(79) 415.?
Cuda:9.0
Cudnn:7.0.5 and 7.1.3
Gcc:gcc-5 gcc-6 gcc-7(視情況切換版本
G++:g++-5 g++-6 gcc-7(視情況切換版本
tensorflow-gpu:1.5~1.12

這都不是重點,直接進入業配文(誤

你有verify cuda 及 cudnn版本嗎

nvcc -V

cat /usr/local/cuda/include/cudnn.h | grep CUDNN_MAJOR -A 2
or
cat /usr/include/x86_64-linux-gnu/cudnn_v*.h | grep CUDNN_MAJOR -A 2

最好cuda安裝過程順便安裝cuda sample測試一下!!
保險一點cudnn也可以跑一下sample
謎之音:如果是cuda cudnn 沒裝好,應該要撤底刪除乾淨cuda cudnn等等檔案,然後再重裝一次應該就好了。
再來就是說tensorflow-gpu pip不能支持cuda 10.0,需要自行編譯

0
黑暗小兵
iT邦新手 5 級 ‧ 2019-01-08 09:56:02

不知道發文的大大,成功了嗎?

我也分享實際測試環境:
作業系統: Ubuntu 18.04
主機:i7-3770
顯示卡: GeForce GTX 1050 2G
顯卡驅動:nvidia-driver-390
更新顯卡驅動:
在【軟體與更新】-> 額外驅動程式->找到使用NVIDIA driver metapackage 來自 nvidia-driver-390 (專有)

CUDA:9.0
tensorflow版本:1.12.0
GCC: Ubuntu18.04預設為7.2 需要降版本,我是降到 gcc-4.8
cuDNN: v7.0.5
我後來有使用anaconda 去建立要跑tensorflow的環境,也有成功建立,供您參考。

參考資料:
How To Install Tensorflow-GPU (1.8) on Ubuntu 18.04

我要發表回答

立即登入回答