iT邦幫忙

0

Cisco router PPPOE轉固定IP

各位IT人好,如標題
已爬過版上文章,相同的問題有人提問過,但可惜最佳解答已經網址失效

最近公司換了新的ISP,連線方式由PPPOE改成固I
已用小烏龜連接電腦直接設定IP,一切均正常

但若設定在Router後則連線失敗,router ping的到8.8.8.8
但用戶端卻只有微信可以使用,其他yahoo, google, 百度等等的全都不行

已請教過身邊朋友,大家看過Config都覺得設定沒問題
但就是無法連線~"~ 所以發文尋求解答
以下為configuration

interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 192.168.5.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address xx.xx.xx.xx xx.xx.xx.xx (ISP給的IP和mask)
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Dialer1
ip address 123.456.789.000 255.255.255.0
ip mtu 1480
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
shutdown
dialer pool 5
dialer-group 5
ppp authentication chap pap callin
ppp chap hostname abc
ppp chap password 0 abc123
ppp pap sent-username abc password 0 abc123
no cdp enable
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
!
ip nat inside source list 100 interface GigabitEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 xx.xx.xx.xx (ISP給的gateway)
!
!
!
access-list 100 permit ip 192.168.0.0 0.0.0.255 any
access-list 100 permit ip 192.168.2.0 0.0.0.255 any
access-list 100 permit ip 192.168.3.0 0.0.0.255 any
access-list 100 permit ip 192.168.5.0 0.0.0.255 any
access-list 100 permit ip 192.168.7.0 0.0.0.255 any
access-list 100 permit ip 192.168.8.0 0.0.0.255 any
!
control-plane

看更多先前的討論...收起先前的討論...
補覺鳴詩 iT邦研究生 1 級 ‧ 2019-06-09 21:10:09 檢舉
下兩個指令看看
show ip nat statistics
show ip nat translations

然後避免影響
interface Dialer1 沒用到的東西就 no 掉吧
想要留的話 留 config 就好
了解~我第一次設定時設定不過,有試著把dialer1拿掉,可還是一樣
今天中午午休再來測試一次看看,設定完再用show ip nat statistics
show ip nat translations 這兩個指令測試看看
補覺鳴詩 iT邦研究生 1 級 ‧ 2019-06-10 15:48:16 檢舉
對了 另外再做一個 clear ip nat translation * 動作
[lovesharepc](/users/20102973)

謝謝你,我後來用show ip nat statistics有看出來是哪裡的問題,router的config是沒問題的,而原來是我user端的DNS也都要改,剛剛才用AD重新發送新的policy

1 個回答

0
bluegrass
iT邦高手 1 級 ‧ 2019-06-10 09:05:37
最佳解答

en
config t
no interface dialer1
exit
ip dns server
ip name-server 1.1.1.1
exit
copy run start

ping www.google.com

謝謝你,中午午休時我再來試試看多加一個dns server的設定

謝謝你啊,今天中午時我搞定了,確實是DNS問題,只不過不在router上,是在user PC端的DNS設定 XD

我要發表回答

立即登入回答