iT邦幫忙

0

iMAC 變更 php 版本失敗?(LoadModule takes two arguments)

已經有安裝好 php7.3
路徑是在 /usr/local/php5-7.3.8-20190811-205217/libphp7.so

然後開啟 httpd.conf
把原本的 LoadModule php7_module libexec/apache2/libphp7.so 註解
換成
LoadModule php7_module /usr/local/php5-7.3.8-20190811-205217/libphp7.so

卻出現以下錯誤

httpd: Syntax error on line 191 of /private/etc/apache2/httpd.conf: LoadModule takes two arguments, a module name and the name of a shared object file to load it from

但是我往上看,已經沒有相關 PHP 的 LoadModule 存在了⋯⋯

看更多先前的討論...收起先前的討論...
ccutmis iT邦高手 4 級 ‧ 2019-10-16 21:06:34 檢舉
試試:
LoadModule php7_module "/usr/local/php5-7.3.8-20190811-205217/libphp7.so"
froce iT邦大師 1 級 ‧ 2019-10-16 21:44:38 檢舉
我不熟php,但是...
LoadModule takes two arguments
拜託學著看一下debug好嗎?

LoadModule /usr/local/php5-7.3.8-20190811-205217/libphp7.so
只有一個argument...
火爆浪子 iT邦研究生 1 級 ‧ 2019-10-16 21:46:12 檢舉
TO ccutmis
抱歉原本就有加了,還是一樣耶
ccutmis iT邦高手 4 級 ‧ 2019-10-16 22:38:43 檢舉
LoadModule php7_module /usr/local/php5-7.3.8-20190811-205217/libphp7.so
改成
LoadModule php7_module "/usr/local/php5-7.3.8-20190811-205217/libphp7.so"
有試過?
如果試過還是報錯,錯誤訊息還是一樣嗎?
火爆浪子 iT邦研究生 1 級 ‧ 2019-10-16 22:57:48 檢舉
對,我不清楚是不是 high sierra 的關係?
ccutmis iT邦高手 4 級 ‧ 2019-10-16 23:26:48 檢舉
這我就不知道了,還是你改回用 high sierra原本預裝的 php7模組跑就好?
https://medium.com/@soufianerafik/setting-up-php-7-on-macos-high-sierra-714594eadbbe
火爆浪子 iT邦研究生 1 級 ‧ 2019-10-17 01:24:31 檢舉
嗯 只是是 php7.2 版本,我是想說把環境用的至少差不多 7.3.x ,看來是無解

尚未有邦友回答

立即登入回答