iT邦幫忙

1

WordPress 與PHP 版本問題

各位先進好

事情是這樣的,不久前我想要幫我的wordpress網站安裝一個媒體庫的外掛
因為該外掛顯示我當前php版本不符合需求(事後去查,所需版本是php7.0以上)

所以我就嚐試用cPanel裡的php selector更改php版本,怎料這是惡夢的開始

如圖所示,我的php selector只有3個版本可以選擇(我的主機商是HostGator)

狀況變成使用php7.0或7.1都會導致我的wordpress後台和網站顯示大量錯誤,且許多功能無法運作

若是使用php5.4,則是直接整個無法運作,顯示需要5.6以上的版本:

Your server is running PHP version 5.4.45 but WordPress 5.4.2 requires at least 5.6.20.

wordpress己經更新到最新版本,按理來說應該是支援php7.0才對
不曉得為何會有錯誤?也不懂為何預設的版本是5.4的話,為何在我做這些動作之前
能正常運作?

我目前想的到的解決方法:

方法1.放棄安裝那個外掛,想辦法將php版本改為5.6.2
方法2.想辦法解決在php7.0之下運作wp的錯誤

但不管是方法1還是方法2我都不曉得該怎麼做Q_Q
在這裡先感謝願意抽空回文的版友orz

-----更新-----

己發現更換php7.0後的錯誤為布景主題所致
移除布景主題並更新後可解決,
只是這樣變成要以前做的許多細部修改要重用的大工程....
若有方法1的解決途徑仍會考慮

1
咖咖拉
iT邦研究生 4 級 ‧ 2020-06-14 08:45:15

先將檔案資料庫都備份後

將你的WORDPRESS 全部更新
現在WP也建議採用 PHP 7.3 及MySQL 5.6 或更新版本
基本上更新到最新版本都不會有問題

插件外掛不支援PHP 7 的話建議找替代的

0
海綿寶寶
iT邦大神 1 級 ‧ 2020-06-14 10:08:33

方法1是長痛;方法2是短痛
就看你自己怎麼選擇了

我朋友三不五時就會收到主機商發來的通知(自動升級WordPress)
由於使用用途/方式和你不一樣
所以我朋友的原則就是「把客製化的部份降到最少,幾乎不客製」
為的就是應付三不五時的升級

儘管如此
我朋友上次在轉 php 7.0 的時侯
也是改 SQL 部份的 code 改的頭昏眼花
不過改完了也鬆了一口氣

0
billson
iT邦見習生 ‧ 2020-06-14 17:57:17

我們的網站是 Wordpress 5.4.x https://blanktee.hk 只能用 PHP 7.2,當升級至 7.3/7.4 都是出現錯誤,最後找到的原因是 Redis 暫時未有 7.3 的 extension。唯有用回 7.2。所以作升級 PHP 時要準備好很多測試。

我要發表回答

立即登入回答