iT邦幫忙

0

[已解決]連入POSTFIX 後傳送附件失敗 lost connection after DATA

這狀況應該是這兩天陸續增加,最後發現是對方SERVER強制使用TLS(微軟更新?)造成我這個問題,因為我的SERVER沒開TLS,這些強制TLS的公司當要傳DATA時碰到我的SERVER不會自動跳回未加密模式就會傳輸不成功,並非我的防火牆阻擋,昨天把SERVER加入TLS功能後今天這些不正常的客戶就都正常了
lost connection after DATA這狀況還發生在一家客戶,他們家防火牆稽核很嚴謹,因為檔名或是郵件內字眼被阻擋,也會造成這訊息,結果也是揮我防火牆阻擋他們MAIL,結果我提醒她只有那封信有問題寄不過來,其他都正常,他才找到問題!
..................
今天忽然發生好幾家客戶連入連入POSTFIX 後傳送附件失敗 lost connection after DATA ,但這些失敗的客戶只寄沒有附加檔案的MAIL是可以過來的,但不是每家客戶都有這狀況,像我請有問題的客戶寄到我自家的SERVER是OK的,我再用自家SERVER寄到公司也是OK的,但客戶直接寄到公司就不行。
LOG大概如下

Jul  1 17:12:05 mail postfix/cleanup[29177]: B70A17A0308: hold: header Received: from AAA.AAA.com (AAA.AAA.com [123.123.123.123])??by BBB.com (Postfix) with ESMTP id B70A17A0308??for <csop-g@BBB.com>; Thu,  1 Jul 2021 17:12:05 +0800 ( from AAA.com[123.123.123.123]; from=<AAA@AAA.com> to=<BBB@BBB.com> proto=ESMTP helo=<AAA.AAA.com>

Jul  1 17:12:05 mail postfix/cleanup[29177]: B70A17A0308: message-id=<a7fbd47f479e483db4308252f1ff0179@AAA.com>

Jul  1 17:12:05 mail postfix/smtpd[24424]: lost connection after DATA from AAA.AAA.com[123.123.123.123]

Jul  1 17:12:05 mail postfix/smtpd[24424]: disconnect from AAA.AAA.com[123.123.123.123]

請問有什麼方式可以釐清問題?我已經確認防火牆沒有擋 MAIL SERVER的 IPTABLE也沒有擋,因為我不可能在客戶環境下寄信給自己測試,所以滿困擾的。

看更多先前的討論...收起先前的討論...
ayu iT邦好手 2 級 ‧ 2021-07-01 20:42:37 檢舉
您有跑MailScanner?
fireflybug iT邦研究生 5 級 ‧ 2021-07-01 21:15:33 檢舉
有,但我看至少要在等接收完成MailScanner才會接手,lost connection after DATA在MailScaner接手前就發生了
Jul 1 21:04:06 mail postfix/smtpd[23805]: disconnect from
Jul 1 21:04:06 mail MailScanner[23162]: New Batch: Scanning 1 messages, 2376 bytes
有防火牆吧?試著設定規則讓smtp能通過先
fireflybug iT邦研究生 5 級 ‧ 2021-07-02 11:20:14 檢舉
已解決
jenho iT邦新手 5 級 ‧ 2021-07-02 12:51:36 檢舉
請問fireflybug這問題後來怎麼解決的?
我們公司從7/1起一直有這狀況
fireflybug iT邦研究生 5 級 ‧ 2021-07-05 08:48:22 檢舉
果然還有別人,如果你的SERVER沒開啟TLS加密傳輸,那就是我推斷的,對方應該適用EXCHANGE,然後應該有更新,造成傳送DATA時使用TLS,SERVER沒支援當然會斷線,但並不是防火牆的問題。正常來說沒有TLS,SERVER溝通自己要轉成普通傳輸模式。這是微軟的問題,猜測更新後可能要手動開啟普通傳輸,不然跟沒有TLS傳輸的SERVER絕對會有問題。

1 個回答

0
msnman
iT邦研究生 1 級 ‧ 2021-07-01 23:09:09

https://ithelp.ithome.com.tw/upload/images/20210701/200870143KyRpVQSfB.png

你自已這樣設定看看,是不是會發生同樣的問題。

fireflybug iT邦研究生 5 級 ‧ 2021-07-01 23:53:00 檢舉

您這個答案我已經查詢過 不是這個問題 是外面的寄信過來 準備要傳送DATA時出現的錯誤斷線

msnman iT邦研究生 1 級 ‧ 2021-07-02 08:47:53 檢舉

這個就是外面電腦設定連線的時間太短,伺服器還沒結束,但發送端已經結束,所以,失去連線。

我要發表回答

立即登入回答