iT邦幫忙

0

Cisco 2960設定trunk異常

virgil0711 6 年前17713 瀏覽

我使用console線設定Cisco 2960做trunk(Interface為Gi1/0/23以及Gi1/0/24)
如下圖示

接著使用show interface trunk指令驗證設定的結果
但是發現都設定不上去
還有勞IT邦前輩指點迷津
在此先謝過了

在此之前,我曾經嘗試過以下2種設定
(IP環境為Cisco設備vlan ip為192.168.5.53/24
NB的IP設定為192.168.5.60/24)

第1種
將網路線接至24 port與NB對接
使用telnet至192.168.5.53做設定
會出現以下兩張圖示(發現只有24port 有加入trunk)

第2種
將網路線接至23 port與NB對接
一樣使用telnet至192.168.5.53做設定
會出現以下兩張圖示(發現只有23port 有加入trunk)

2 個回答

6
pu88
iT邦新手 2 級 ‧ 6 年前
最佳解答

依大大的需求, 應該只要這樣設定即可
conf t
interface Gi1/0/23
switchport trunk allowed vlan 1
switchport mode trunk
!
interface Gi1/0/24
switchport trunk allowed vlan 1
switchport mode trunk

wri

試看看吧~~

pu88 iT邦新手 2 級 ‧ 6 年前 檢舉

如果是要將2個port合併頻寬的話,則用下列方法即可
conf t
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
interface Gi1/0/23
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
!
interface Gi1/0/24
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
wri

virgil0711 iT邦新手 2 級 ‧ 6 年前 檢舉

恩,我之前的設定其實就是走合併頻寬的方式
還是很謝謝您提供非合併頻寬的設定方式
另外請教您
如果我要把現在合併頻寬的Interface Po1打掉
改成獨立兩個trunk port
是直接下您所寫的指令即可???
conf t
interface Gi1/0/23
switchport trunk allowed vlan 1
switchport mode trunk
!
interface Gi1/0/24
switchport trunk allowed vlan 1
switchport mode trunk

還是要先把interface Port-channel1刪除???

pu88 iT邦新手 2 級 ‧ 6 年前 檢舉

理論上,
interface Port-channel1
switchport trunk encapsulation dot1q
channel-group 1 mode active
都要拿掉才對,您可以試看看~

2
zackhuang
iT邦新手 2 級 ‧ 6 年前

你沒發現

根據你的測試中,都是有接上設備,那個port的trunk才會起來嗎?

看更多先前的回應...收起先前的回應...
virgil0711 iT邦新手 2 級 ‧ 6 年前 檢舉

其實我是想確認,我所打的指令,是不是確實有把Interface Gi1/0/23和Gi1/0/24都設定成trunk port,如果有設定成功,那為什麼接console線使用查詢指令show interface trunk卻沒有顯示任何資訊? 我想問的是,要如何知道我設定的兩個trunk port是OK的?
我這兩個port(Interface Gi1/0/23和Gi1/0/24)未來是打算一個接3com有帶tag的switch,另一個port就是擴接用(如果未來終端還需要網點額外增加網路設備時),以上所有的測試都是NB與Cisco 2960對接

virgil0711 iT邦新手 2 級 ‧ 6 年前 檢舉

後來跑show run為如下資訊,我想應該是設定完成的
interface GigabitEthernet1/0/1-22
switchport access vlan 103
switchport mode access
!
interface GigabitEthernet1/0/23
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet1/0/24
switchport mode trunk
channel-group 1 mode on

zackhuang iT邦新手 2 級 ‧ 6 年前 檢舉

就像前面說的

要接上去trunk才會起來
sh interface trunk 才看的到

可是你說兩個port 要接不同設備
那為何把它綁成同一個etherchannel?

virgil0711 iT邦新手 2 級 ‧ 6 年前 檢舉

所以我應該要把channel-group 1 mode down下來才是
其實我們是要做多種測試
後來channel-group的部分是測試成功了(兩台C2960的23以及24port都做channel-group trunk port)
我很好奇,如果有一台做channel-group,另外一台的23以及24port是分別獨立的trunk,然後使用2條網路線分別接2台設備的23以及24port,這樣頻寬應該是3G??

突然想起來我那時候應該測試看看,頻寬是否可以跑到4G(2台設備都做channel-group trunk),可惜沒有測試到...

fantsyss iT邦新手 2 級 ‧ 6 年前 檢舉

設定trunking嗎,還是802.1q,這邊看起來好像是tag vlan居多,抱歉小弟沒有玩過cisco的設備,所以不是很確定。

假如要合併頻寬應該是用trunking的功能沒錯。這樣接2條專線時頻寬會增加一倍。

zackhuang iT邦新手 2 級 ‧ 6 年前 檢舉

2個giga port 最多也才2G不是嗎
為什麼可以跑到4G?

上下傳一起算?

我要發表回答

立即登入回答