iT邦幫忙

0

兩台電腦間的區網連線問題 及網路卡介面卡等基礎觀念問題

roy26807727 1 年前5092 瀏覽

最近入手一台二手電腦 win7
我原本使用的電腦 winXP


原本的上網架構線路 社區網路拉線接到家中無線AP XP電腦插無線網卡上網
係因沒無線網卡了 所以我用網路線插到XP&win7 來讓win7吃XP的網路上網
插上後在XP網路連線內設定 (由於不太會設定)
當下點選無線網路&區網 在按橋接器連線(1)
再來對無線網路 右鍵 內容 共用 勾選允許其他使用者透過此電腦網路來連線(2)
再來依照 網路設定精靈 設定家用或小型辦公室網路設定 (3)
再來依照 新增連線精靈 設定進階的連線(序列 平行 紅外線連接阜 COM1~2)
進階的連線又細分 接受連入連線(4) 直接連線到另一台(5)

以上我最少用了5種不同的方式來設定 眼明的人一看就知道我多此好幾舉了

win7是抓得到網路可以上網了 但是每次關機後 再開機 網路又會抓不到
win7端都會顯示無法辨識的網路
每次都還要我在XP端透過網路連線精靈設定家用或辦公網路
或是橋接器來抓網路
或是我把網路線拔起來在插下去來抓網路 (有時成功有時失敗)
--
這幾天測試後發現 我XP完全開機後 預載系統資料 等網路讓系統讀完後
我在開機win7 網路就抓得到了 這是為什麼呢? (問題1)
--
今天xp還沒完全登入我就開機win7了 不意外 win7端網路抓不到
接著我在XP端 網路連線設定了區網的一些設定
右鍵內容 Internet Protocol(TCP/IP)我把裡面IP位子調自動抓取
及區網 防火牆>進階啟用了DHCP等服務
接著停用在啟用XP端 win7端的區網 然後拔起網路線在插下去
接著不可思議的事情發生了
XP端 WIN7端的區域網路都顯示 已拔除網路電纜 然後一個紅色小叉叉
莫名其妙的是 上述設定後 兩個電腦端都重開機不下10次了
而且區網都有啟用 後來也把上述區網內容 防火牆設定 調回來
關防毒軟體(AVG) 關網路防火牆
天殺的 根本鬼打牆 區網讀不到就是讀不到 都是顯示紅色叉叉已拔除網路電纜
我在msconfig 系統服務 啟動我還找不到可以把區網關閉的東西? 再來排除網路線路問題 因為我換過線測試 狀況依舊 在軟體上的設定是能把硬體給搞壞嗎(網路介面卡)
(只有在電腦重開機尚未登入桌面時 另台電腦區網圖示短暫顯示抓取網路位子 接著又跳回已拔除網路電纜)(但在上述區網短暫抓取時 網路線燈號完全沒亮)
試問為什麼會這樣? (問題2)
--
我想著這台XP到底有什麼問題 我幾乎準備放棄了 我把無線網卡從XP拔下先給win7用 接著在XP上點選裝置管理員 網路介面卡 右鍵內容 看著上面的資訊
(我的網卡名稱 Realtek Rtl8168/8111 PCI-E Gigabit Ethernet NIC)
點到驅動程式頁籤時我看到驅動程式日期 2003年左右 就想說來更新看看
畢竟抱著死馬當活馬醫 因為此處網路介面卡沒沒顯示 Error
到了官網到來導向下載點後 我點倒數第2個選項
WinXP and Server 2003 Auto Installation Program (SID:1699998)
各位可以去Google一下我的網路介面卡 第一個Realtek官網 點進去後
倒數第二個選項
WinXP and Server 2003 Auto Installation Program (SID:1699998)
我下載後也在XP完成安裝後 天殺的 XP端&win7端 區網圖示終於有訊號了
顯示無法辨識的網路 而不是紅色叉叉已拔除網路電纜
奇怪的是我安裝完後我網路介面卡的名子變成了
Realtek PCIe GBE Family Controller
--
Realtek Rtl8168/8111 PCI-E Gigabit Ethernet NIC (舊名稱)
Realtek PCIe GBE Family Controller (新名稱)
為什麼會這樣呀? 硬體更新完驅動改變名子這應該不是常態吧? (問題3)
--
接著在win7端 網路連線 對無線網路(我無線網卡插在win7) Wi-Fi右鍵內容 共用
勾選允選其他使用者透過此電腦網路來連線 下方列表拉選區域網路
接著 兩端電腦區網圖示正常...並且兩端都可以上網了....
..原來按共用並拉選區網就好 我還在喬接 網路精靈設定老半天
--
人該抱著從錯誤中學習經驗並成長的態度
所以上述 三個問題 大致生成的原因是什麼?
還請各位多多回答 感恩~~ 小弟敬上十萬分的敬意

看更多先前的討論...收起先前的討論...
外獅佬 iT邦大師 1 級 ‧ 1 年前 檢舉
已讀...看不懂問題嘆氣
weiclin iT邦高手 7 級 ‧ 1 年前 檢舉
問題1: 你要讓 xp 分享網路給 win7, 那當然要先等 xp 開好, 不然 win7 失敗以後會等一段時間才重試
問題2: 你不是解決了嗎?大概軟體有 bug
問題3: 正常, 而且也不算少見
WilliamHuang iT邦大師 1 級 ‧ 1 年前 檢舉
他的問題要寫專案報告了
~~~
所以 已讀 太長 不回
^^
roy26807727 iT邦新手 5 級 ‧ 1 年前 檢舉
0.0 後來我問過我朋友 他說電腦對接是不是要跳線呀?
我只是拿一般的RJ45對接而已
上述案例 我如果win7比XP先載入 XP網路讀好後 兩台電腦都抓不到耶

對呀 是解決了 只是覺得很奇怪想來問問
0
WilliamHuang
iT邦大師 1 級 ‧ 1 年前

所以 已讀 太長 不回
^^

0
chinese0925
iT邦新手 4 級 ‧ 1 年前

己讀 太長 問題重點沒看到 暈

0
勇者之歌
iT邦新手 2 級 ‧ 1 年前

已讀 不想解 文章太長...我連看都懶得看還叫別人google...自己解吧

我要發表回答

立即登入回答