iT邦幫忙

0

使用Xampp-Mysql功能列,跑出#1064錯誤訊息。

Damocles 1 周前1523 瀏覽

http://ithelp.ithome.com.tw/upload/images/20170314/20103670nx99zn9uIj.jpg
如上圖,按下資料列的刪除跑出錯誤訊息,想請教前輩是否有遇過是怎麼解決的呢??
註:三個功能都一樣

2 個回答

0
麗麗
iT邦研究生 5 級 ‧ 1 周前
Damocles iT邦新手 5 級 ‧ 1 周前 檢舉

您所轉載的頁面裡面是使用者的查詢式有誤,
但是我這邊的情況是"功能列(編輯、複製、刪除)"點下去會跑#1064,
並非使用者"自己打"的查詢式有問題,
還是感謝您的回答~謝謝!!

麗麗 iT邦研究生 5 級 ‧ 1 周前 檢舉

SORRY QAQQQ,我以為這個方法也可以套用在刪除上OTZ.

Damocles iT邦新手 5 級 ‧ 1 周前 檢舉

沒有關係的,提出問題就是希望能有人可以討論、指導,
也很感謝你的指導~麗麗

0
jerry00218
iT邦研究生 4 級 ‧ 1 周前

我覺得是因為你沒有設定主鍵,設定之後再試看看

看更多先前的回應...收起先前的回應...
Damocles iT邦新手 5 級 ‧ 1 周前 檢舉

事實上我打從資料表在設計時就已經有KEY了,
所以這個問題跟有沒有KEY是沒有關係的:)

fillano iT邦超人 1 級 ‧ 1 周前 檢舉

那貼一下你的create table script來看看吧...缺unique key或primary key的話,編輯的介面(就那幾個按鈕跟checkbox)不會出現。現在的問題是,為什麼phpmyadmin沒有產生where條件,導致sql語法錯誤。

知道phpmyadmin的版本嗎?

Damocles iT邦新手 5 級 ‧ 1 周前 檢舉

這一聽就知道是行家說的話!! 真不愧是fillano前輩
Apache/2.4.23
MySQL/4.5.1
原資料表是外部匯入的,之後新增了新資料表(測試用),
也是一樣(3個功能列按下去跳#1064)

jerry00218 iT邦研究生 4 級 ‧ 1 周前 檢舉

為什麼還是沒有 phpMyAdmin 的版本…

Damocles iT邦新手 5 級 ‧ 1 周前 檢舉

就是 "4.5.1" 呦:)

我要發表回答

立即登入回答