iT邦幫忙

7

Fedora 9 透過 yum update 更新的問題解決

這兩天yum update會碰到yum及yum-utils更新錯誤的問題,而無法更新其他的套件,會有類似的訊息出現:

--> Running transaction check
---> Package yum-utils.noarch 0:1.1.16-1.fc9 set to be updated
--> Processing Dependency: yum >= 3.2.19 for package: yum-utils
--> Finished Dependency Resolution
yum-utils-1.1.16-1.fc9.noarch from updates-newkey has depsolving problems
  --> Missing Dependency: yum >= 3.2.19 is needed by package yum-utils-1.1.16-1.fc9.noarch (updates-newkey)
Error: Missing Dependency: yum >= 3.2.19 is needed by package yum-utils-1.1.16-1.fc9.noarch (updates-newkey)

https://fedoraproject.org/wiki/Enabling\_new\_signing\_key可以看到,利用這個指令:

yum update --exclude yum --exclude yum-utils

就可略過這兩個yum的套件,而順利更新其他;
(在這過程中,會問是否要import新的PGP的key,
就會自動import進來,這樣再做以下兩個yum更新時,
就不會有缺少新的gpg key之情況發生)
然而再yum update仍會出現這兩個無法update的問題,
這時,先把這兩個rpm抓下來:
http://ftp.ncnu.edu.tw/Linux/Fedora/linux/updates/9/x86\_64.newkey/yum-3.2.19-3.fc9.noarch.rpm
http://ftp.ncnu.edu.tw/Linux/Fedora/linux/updates/9/x86\_64.newkey/yum-utils-1.1.16-1.fc9.noarch.rpm
然後下安裝此兩個rpm套件的指令:

yum update yum-3.2.19-3.fc9.noarch.rpm yum-utils-1.1.16-1.fc9.noarch.rpm

這樣,被卡到的套件也就安裝完成,不會再有錯誤狀況了!


1 則留言

0

謝謝分享咯!

我要留言

立即登入留言