iT邦幫忙

0

請問我的 php5.1.4 +IIS 6+mySQL+phpmyadmin v3.1.5 or v3.2.0 不能運作?

請問各位先進
我有個環境是用php5.1.4 + IIS 6 + mySQL 架設的網頁
由於 突然 mysql 不能運作,所以想要安裝 phpmyadmin 來試著管理
查到了一些設定步驟,照以下連結中的教學文件去設定好虛擬目錄了
可是裝完設定完後,想瀏覽管理介面時,卻會顯示出需要 PHP 5.2+
(會寫PHP 5.2+ is required)
但是我安裝的 phpmyadmin 是 v3.2.0 不行後又換成 v3.1.5
看了原始的網站頁面是寫著
Version compatible with PHP 5 and MySQL 5. Currently recommended version
但是我現在不知道我的 mysql 是幾版
我可以怎麼查呢?
謝謝大家
它寫的應該是 php v

外獅佬 iT邦大師 1 級 ‧ 2009-06-30 08:57:34 檢舉
這個....MySQL的最高權限帳號,一直以來都是root啊....
坊間MySQL的書籍還不算少,可以考慮找一本來研究研究。
typerr iT邦新手 3 級 ‧ 2009-06-30 19:43:12 檢舉
因為是在WEB後台登入
當時設定的是網站製作的工程師
所以並不曉得裡面有幾個帳戶
也沒想到WEB後台設定跟mysql 中的帳號會是一樣的...無言
外獅佬 iT邦大師 1 級 ‧ 2009-06-30 22:17:59 檢舉
通常都是這樣的啊....
最慘的是,SQL Server用sa,MySQL用root....
這是很常見的....雖然,前輩都會耳提面命說這是不對的....

1 個回答

12
外獅佬
iT邦大師 1 級 ‧ 2009-06-25 08:34:57
最佳解答
  1. 更改MySQL root 帳號的密碼:mysqladmin -u root password {你的新密碼}
  2. 查詢mysql版本:
    a. 登入mysql:mysql -u root -p
    b. 輸入密碼
    c. use mysql
    d. SELECT version();
看更多先前的回應...收起先前的回應...
typerr iT邦新手 3 級 ‧ 2009-06-25 09:34:08 檢舉

謝謝你
後來不小心猜到密碼了,是公司另一組不常用的
登進 commandline 後,一登入 root 就能看到版本是 v5.0.22
可是這樣也是有符合 phpmyadmin 的需求耶........

外獅佬 iT邦大師 1 級 ‧ 2009-06-25 09:40:33 檢舉

您的問題應該不出在MySQL的身上,那個訊息寫得很清楚:它必須使用PHP 5.2或以上的版本,而您的PHP卻是5.1.4,明顯低於5.2。

建議您到 www.php.net 下載新的、stable的版本,更新PHP之後再試試看吧~~
加油~~

外獅佬 iT邦大師 1 級 ‧ 2009-06-25 09:42:25 檢舉

phpmyadmin的網站有這段說明:
version 3 and later requires at least PHP 5.2 and MySQL 5.

所以,不管是3.1.5或是3.2都必須使用PHP 5.2或更高的版本,請更新PHP吧~~

外獅佬 iT邦大師 1 級 ‧ 2009-06-25 09:43:58 檢舉

另外,官方網站上有提到,如果要使用PHP 5.2以前的版本,請使用phpmyadmin 2.x版
下載位置:http://www.phpmyadmin.net/home\_page/downloads.php

typerr iT邦新手 3 級 ‧ 2009-06-25 18:08:21 檢舉

原來如此~那我試試2.x版先
先謝謝大家

typerr iT邦新手 3 級 ‧ 2009-06-26 23:50:07 檢舉

目前安裝好2.x,好像要設定密碼
試了一些方法都不行
有人有正確的步驟或是操作頁面嗎?謝謝大家

我要發表回答

立即登入回答