iT邦幫忙

0

8139c 在DOS下的MSCLINET無法安裝成功

很奇怪的是相同的安裝步驟,套用在DLINK 530TX可以正確ping 出去,
但realtek 的8139C就是ping 不出去,
有大大可指導一下問題出在那嗎?

utopia iT邦新手 3 級 ‧ 2010-11-15 16:55:16 檢舉
感謝兩位大大回應,
最後查出原來是硬碟有壞軌的關係!!

2 個回答

6
逮丸逮丸
iT邦大師 1 級 ‧ 2010-09-27 10:05:33
最佳解答

utopia提到:
8139c在win98下可正常運作。

在win98能通的時候,
查查看該網卡的IRQ及I/O值為何,
再用這些值做 MsClient 網卡驅動時的參數試試。

看更多先前的回應...收起先前的回應...

挖,好懷念的Net For DOS

<洩漏年紀>

utopia iT邦新手 3 級 ‧ 2010-09-29 23:19:19 檢舉

有找到IRQ:11 I/O: DE00 H
但如何設定到MsClient 的參數呢?
(setup過程中沒有可改這二項的地方)

參考樓下的驅動程式下載,選那DOS、Packet Driver,
解開後執行 rtspkt,
試試 rtspkt.com 或 rtspkt.com 0x60 或 rtspkt.com 0x61 看有什麼結果?
並也參照:
http://home.phy.ntnu.edu.tw/~roba81/msclient.htm
製作步驟 那一節的步驟,
把 dlink driver 的相關字樣,

將drivername=DLKFET$這一行改成
drivername=RTSND$
...
將netcard=DLKFET.DOS這一行改成
drivername=RTSND.DOS

細節請留意該文的說明。

utopia iT邦新手 3 級 ‧ 2010-10-01 23:08:51 檢舉
  1. rtspkt.com 0x60 或 rtspkt.com 0x61 的結果都是:
    Line Speed 100Mbps
    System: [345]86 processor, PCI bus, Two 8259s
    Packet driver software interrupt is 0x60
    Interrupt number is 0xB
    I/o port is 0xDE00
    My Ethernet address is 00:B1:26:01:8F:38

然後還是不通。

2.觀察二張網卡開機過程中,出現過的訊息唯一只有一處不同:
RUN c:\net\netbind.exe時,dlink無訊息,
8139 卻出現Fast Ethernet board's Ethernet Address:FFFFFFFFFFFF

請問大大這要從何debug?

6
andrewlee
iT邦研究生 5 級 ‧ 2010-09-27 14:04:44

Realtek 8139C 的驅動程式應該跟 DLINK 530TX 不一樣吧~
請先下載 RealTek 8139 Series NDIS2 或 Packet Driver 試試!
http://www.realtek.com.tw/DOWNLOADS/downloadsView.aspx?Langid=1&PNid=14&PFid=6&Level=5&Conn=4&DownTypeID=3&GetDown=false

另設定請參考此篇網文 -
http://tinux.no-ip.com/wordpress/?p=5

utopia iT邦新手 3 級 ‧ 2010-09-29 23:23:01 檢舉

根據大大提供的網文,
仔細比對了一下,
的確如網文所指示的設定一樣,
所以ping 127.0.0.1是ok的,但其他就不行...
換上530tx重run msclient就又可以...無語...

我要發表回答

立即登入回答