iT邦幫忙

0

ubuntu 10.10 無法使用apt-get安裝軟體

各位先進大家好
小弟目前使用的OS是 ubuntu10.4 ,後來升級到10.10
升級之後非常穩定,直到我apt-get purge samba 之後
要安裝軟體都會出現下列訊息而無法安裝,

apt-get install gperf
Reading package lists... Done
Building dependency tree
Reading state information... Done
vim is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
freenx-session-launcher : Depends: freenx-server but it is not installable or
nxnode but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

我試著用apt-get -f install gperf安裝
依然出現那段訊息

請問各位先進有沒有甚麼方法可以解決這個問題呢
感恩~~

2 個回答

4
Tony
iT邦高手 4 級 ‧ 2011-10-26 08:34:06
最佳解答

試著執行 sudo apt-get -f install 看看, 它應該會自行安裝缺少的套件

cjtjava iT邦新手 3 級 ‧ 2011-10-26 09:59:09 檢舉

sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
freenx-session-launcher
0 upgraded, 0 newly installed, 1 to remove and 69 not upgraded.
After this operation, 102kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 186134 files and directories currently installed.)
Removing freenx-session-launcher ...
chmod: cannot access `/usr/bin/nx-session-launcher-suid': No such file or directory
dpkg: error processing freenx-session-launcher (--remove):
subprocess installed pre-removal script returned error exit status 1
Errors were encountered while processing:
freenx-session-launcher
E: Sub-process /usr/bin/dpkg returned an error code (1)

他說缺少`/usr/bin/nx-session-launcher-suid'
我到系統中去看實際上真的沒有這個檔案或路徑
所以還是裝不起來

還是我哪裡有做錯呢

cjtjava iT邦新手 3 級 ‧ 2011-10-31 08:05:09 檢舉

感謝各位先進的幫忙
上網爬很多天的文,剛好也有人遇到相同狀況,也是類似使用sudo apt-get -f install 去強制安裝漏掉的軟體,卻無法安裝的情況。
他的方法是將/var/lib/dpkg/status文件中,那個軟體名稱標記下的資料都刪除掉再重新安裝,試過之後真的可以解決問題。
感謝大家的幫忙,感恩~~

4
zivhsiao
iT邦新手 4 級 ‧ 2011-10-26 08:09:29

看起來有些東西不存在
freenx-server or nxnode
試試看安裝上面這兩個,再安裝你要安裝的套件

我要發表回答

立即登入回答