iT邦幫忙

0

關於 jQuery 在 IE 8 上的錯誤訊息

你好,我用的 jQuery 版本是 2.1.1 版的,用IE 8 瀏覽頁面會出現以下錯誤訊息。
但是相同的網頁在 Chrome 和 Firefox 都是正常。
錯誤訊息如下:

網頁錯誤詳細資料

使用者代理程式: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E; InfoPath.3)
時間戳記: Tue, 27 May 2014 05:52:44 UTC

訊息: 物件不支援此屬性或方法
行: 2
字元: 29694
程式碼: 0
URI: http://192.168.1.106:9001/Resource/Package/jQuery/2\_1\_1/jquery-2.1.1.min.js

感謝回覆。

2 個回答

4
player
iT邦大師 1 級 ‧ 2014-06-11 17:23:45
最佳解答

請使用 jQuery 1.11.1 + jQuery Migrate Plugin 1.2.1
這樣才能夠與舊版的IE或是舊版的jQuery Plugin
保持相容

http://jquery.com/download/

jQuery 版本 2.x 是 IE 9以後的版本用的
1.x版與2.x版是保持功能一致, 也會持續改版的

0
fillano
iT邦超人 1 級 ‧ 2014-05-28 17:34:00

http://jquery.com/browser-support/

請改用jQuery 1.x版本。

guareian iT邦新手 3 級 ‧ 2015-03-06 12:04:53 檢舉

player提到:
使用 jQuery 1.11.1

請問ie要怎麼使用 jQuery 阿?

我要發表回答

立即登入回答