iT邦幫忙

0

C++ 初學者疑問,關於開發用的IDE

匿名 2015-02-13 10:38:534949 瀏覽

大大好,
小弟是C++的初學者,就是完全不會,
然後跑到市面上買了一、兩本書來看的那種,
不過現在卡在IDE的部份...有夠初學了巴

小弟買的第一本書 C++ 的,
裡面建議安裝 Visual Stdio 來寫,
所以從網路下載了 Visual Studio Community 2013 版後,
不能安裝ㄚ疑惑
電腦是Win7的,可是一直顯示需要安裝在更新版本的Windows上,
難道要升級到Win8才給用嗎...

另外公司的電腦都是 XP and IE8 的,
聽說VS 2013 要IE10才能跑,
請問小弟要安裝哪一款 VS 才好呢,毫無頭緒搖頭
當然書本上是沒說到這麼詳細的。

小弟買了第二本 C++ 的書,是Qt的
當然就要下載Qt來安裝啦,
安裝過程非常順利,開心到想說可以不用依賴VS寫C++程式了,
可是當開啟一個新專案,要直接執行時,
顯示什麼 Error. ... MVSC 2013 32bit 的錯誤...

不對阿,根本跟書上兩句話,
Windows 版本直接安裝就可以,本書不再贅述。
不一樣ㄚ!!!!!!!!!!落寞
當然之後下載了 Visual C++ 2013 來安裝了,
從2008 一路裝到 2013,x86 跟 x64,版本都裝了,
Qt還是很堅持不給執行....

小弟無能,連個IDE都用不好,請大大們賜死汗汗

另外請問Qt要裝在公司的XP電腦,是不是要選擇別種版本,
小弟下載的是最新版。

看更多先前的討論...收起先前的討論...
賽門 iT邦超人 1 級 ‧ 2015-02-13 13:35:08 檢舉
我不知道發問人的電腦環境如何。
我以Windows 7 SP1 32位元環境來安裝...

安裝完成的啟動視窗...

第一次啟動時,設定工作環境的Theme...(我跳過Live Account)

進入Visual Studio 2013 Community後,選擇Visual C++專案的畫面...

打開Visual Studio 2013 Community的關於視窗...


我的筆電上裝了不止一種Visual Studio版本...每種版本都活得好好的。
我認為,發問人是否把安裝過程中的錯誤訊息貼出來,這樣比較好幫忙找解決方案。
temo iT邦新手 1 級 ‧ 2015-02-13 17:37:38 檢舉
要不要試試先移除全部Visual Studio再安裝較舊版本?

XP的話Visual Studio 2010可以跑,個人XP是安裝2010版本

Qt沒使用過所以不懂那問題,不過看了一下Qt官網應該最新版Qt5是有說Window7以上有支援

要是怕XP不能跑也可以下載Qt4版本
匿名 檢舉
感謝大大,
小弟用VS 2010版就可以裝了,
好奇怪筆記
匿名 檢舉
小弟將電腦重灌後,
安裝VS 2010跟Qt4就可以跑了,
不過書本是講Qt5的,似乎要找一本Qt4來看了,囧
時代在進步,公司在退步....
temo iT邦新手 1 級 ‧ 2015-02-14 16:55:57 檢舉
Qt5跟Qt4只是差在IDE增減內容吧.......
如果只是學C++,版本沒差多少吧@.@可以先看現有的書去做看看
2
外獅佬
iT邦大師 1 級 ‧ 2015-02-13 11:01:03
最佳解答

應該是卡在Win Phone 8.1 Emulator的部份吧
Win phone 8.1模擬器,需要Hyper-V,Win7沒有Hyper-V
這部份選擇不要安裝就好了

看更多先前的回應...收起先前的回應...
外獅佬 iT邦大師 1 級 ‧ 2015-02-13 11:02:21 檢舉

C++用什麼寫?
基本上notepad就夠了
編譯的時候自己找compiler就好了
IDE不是很重要

外獅佬 iT邦大師 1 級 ‧ 2015-02-13 11:03:24 檢舉

學C++,個人是比較建議使用Code::Blocks

匿名 檢舉

感謝大大,
小弟這就來研究下

wiselouCode::Blocks提到:
Code::Blocks

尼克 iT邦高手 1 級 ‧ 2015-02-13 14:44:32 檢舉

建議若是學C/C++語法,不要被IDE環境稿死先。暈

0
wwx
iT邦好手 1 級 ‧ 2015-02-14 15:15:23

VC6,BCB5,Dev-C++4.9.9.1 或是更老的版本
都可以不用安裝就能用 Win95~Win8.1 通通都能用

0
player
iT邦大師 1 級 ‧ 2015-02-14 17:14:06

關於IDE
你可以找舊版的
Visual Studio Express
http://www.visualstudio.com/downloads/download-visual-studio-vs

0
eric9991517
iT邦新手 5 級 ‧ 2015-03-12 08:26:06

不能安裝或許還有一個原因喔
須升級到Service Pack1

我要發表回答

立即登入回答