iT邦幫忙

0

(centos5.8+apache2.2.3+php5.3+mysql5.0建置問題)

CMAN 2016-01-12 17:32:212109 瀏覽

各位先進好~
小弟我目前在centos5.8下安裝apache2.2.3+php5.3+mysql5.0
不知道能不能建議一下小弟通常php常用的額外套件有哪一些
目前裝的是apache2.2.3、mysql5.0、php53-common、php53-gd、php53-5.3、
php53-mbstring、php53-mysql、php53-pdo
因為我不想用Appserv或wamp的套件,用linux來裝一個起來,在Appserv可以使用
但我在linux環境下,我的網頁雖然出的來,但是,圖片、表格都看不到.....連後台管理登入都不能了
一直在想我是少裝套件嗎?~~或者是哪裡可以知道基本LAMP該裝那些,運作上比較不會有瓶頸呢?
因為網路上找了一段時間了.....但是就是試不出來嘆氣
所以想要發問一下><"
如果有需要多一些線索 我會再提供>~<
還請各位幫忙~感溫謝謝

看更多先前的討論...收起先前的討論...
weiclin iT邦高手 6 級 ‧ 2016-01-12 19:22:36 檢舉
通常看 apache error log 可以知道缺了什麼東西
CMAN iT邦新手 4 級 ‧ 2016-01-12 21:05:49 檢舉
好! 我查查><
Heracles iT邦新手 5 級 ‧ 2016-02-25 18:07:04 檢舉
現在回不知道會不會太晚 ...

話說 CentOS 5.8 真的太舊了,如果是 x86 的 CPU 那至少用到 6.7,如果是 x64 的 CPU 那就直上 7.x 吧。

至於 LAMP 或 LNMP 的安裝,前陣子寫了教學文,LAMP 或是 LNMP 任君選擇。
[CentOS 7] 整合 Apache、MySQL、PHP 7 組成 LAMP Server
[CentOS 7] 整合 Nginx、MariaDB、PHP 7 組成 LEMP Server
CMAN iT邦新手 4 級 ‧ 2016-04-07 12:17:19 檢舉
哇~比較新的安裝step耶
感謝您的分享
開心

另外我有找到問題了~~~
原來是php.ini的short_open_tag設定問題
預設off只會認<?php ?>
設為on後就可以看<? ?>
開心

參考網址:http://bojack.pixnet.net/blog/post/28075277-%E3%80%90%E7%A8%8B%E5%BC%8F%E3%80%91php---short_open_tag

1 個回答

4
wiseguy
iT邦超人 1 級 ‧ 2016-01-13 09:40:16
最佳解答

tingsi8642提到:
圖片、表格都看不到.....連後台管理登入都不能了

這看起來跟 php 套件一點關係也沒有,因為 php 不負責解譯與展現 html。
除非你的圖片跟 html 是由 php 動態產生,那麼圖片就需要 GD 套件,至於 html 或許你資料來自資料庫,就得看是搭配什麼資料庫,安裝相對應的套件。比如你使用 mysql,得看你的 AP 是以哪一套 API 寫的 (mysql/mysqli/pdo_mysql/mysqlnd),再裝對應的套件。
套件不是裝越多越好。得看你需要什麼再裝。要不然 php 會變很肥,限制你系統所能接受的連線數量。

看更多先前的回應...收起先前的回應...
wiseguy iT邦超人 1 級 ‧ 2016-01-13 09:45:21 檢舉

題外話,你的系統版本至少落後 10 年以上,你要不要考慮最新的版本:
CentOS 7.2 + Apache 2.4.18 + php 7.0.2 + MariaDB 10.1.10

CMAN iT邦新手 4 級 ‧ 2016-01-13 15:03:26 檢舉

php看用到什麼再安裝相對應的套件,這我了解了。
不過想問,在虛擬主機商的主機測程式是OK可以跑的,但是我自架就會有trouble,這樣會是什麼問題呢~要從程式碼看嗎
至於要更新到新系統要等等><~

wiseguy iT邦超人 1 級 ‧ 2016-01-14 11:00:22 檢舉

tingsi8642提到:
自架就會有trouble

什麼 trouble 要講啊!不講誰知道是什麼問題?

CMAN iT邦新手 4 級 ‧ 2016-01-19 16:08:32 檢舉

回wiseguy大,是網站後台登入有問題~
有出現畫面,但是登入有問題。php連線mysql帳密有確認過。
還是編寫php上的問題呢

我要發表回答

立即登入回答