iT邦幫忙

1

無法使用 Gmail SMTP port 465 發信

sodoi 2016-12-25 21:14:0219908 瀏覽

請問
我的軟體以前使用 smtp.gmail.com SMTP server 透過 port 465 發 email, 現在卻發信失敗.
我使用 telnet smtp.gmail.com 465 測試, 無回應.
使用 telnet smtp.gmail.com 587 有回應.

因為我的軟體無法使用 port 587, 所以只有使用 Gmail SMTP port 465 一途.

請問 Gmail 已不再支援 port 465 了嗎?

還是 smtp.gmail.com 465 被 ISP 擋掉了?

感謝.

sodoi iT邦新手 5 級 ‧ 2016-12-26 08:25:49 檢舉
使用中華電信 4G 網路上網, telnet smtp.gmail.com 465 也是無回應.

請問 WilliamHuang 兄及 shadowpeople 兄, 你們使用 telnet smtp.gmail.com 465 有回應嗎?

感謝.
ayu iT邦好手 6 級 ‧ 2016-12-26 14:36:53 檢舉
ISP不會擋這個
你換別的Public IP再試試看
有開 SSL 嗎 ? 465 要開 SSL 喔,沒開不給連,不是光PORT 對就行的
WilliamHuang
iT邦研究生 1 級 ‧ 2016-12-26 00:58:38
【**此則訊息已被站方移除**】
1
shadowpeople
iT邦新手 2 級 ‧ 2016-12-26 07:28:48

這邊查詢 Google Mail 的說明,並沒有顯示關閉 465 Port的服務。
https://support.google.com/mail/answer/7126229?hl=zh-Hant

如果是懷疑ISP,或是其他原因,建議可以使用別的網路(例如開放手機4G分享)再透過別的網路 telnet gmail 465 Port 看看是否正常。

sodoi iT邦新手 5 級 ‧ 2016-12-26 08:26:23 檢舉

使用中華電信 4G 網路上網, telnet smtp.gmail.com 465 也是無回應.

請問 WilliamHuang 兄及 shadowpeople 兄, 你們使用 telnet smtp.gmail.com 465 有回應嗎?

感謝.

1
huangsb
iT邦好手 1 級 ‧ 2016-12-26 08:27:32

我剛剛用 Telnet 測了一下,很正常,可以連線。

sodoi iT邦新手 5 級 ‧ 2016-12-26 08:35:24 檢舉

我的 firewall 是關閉的.
請問是否是 Windows 7 的設定有問題?

huangsb iT邦好手 1 級 ‧ 2016-12-27 08:22:24 檢舉

我剛剛用程式透過 gmail 587 port 寄信,得到下列的錯誤訊息:

SMTP 伺服器需要安全連接,或用戶端未經驗證。 伺服器回應為: 5.5.1 Authentication Required.

應該是我的密碼驗證不過。你要確定一下錯誤訊息是什麼,從錯誤訊息可以了解遇到了什麼問題。另外,也要確定你用的是應用程式密碼,因為程式不能用網頁登入的密碼。

huangsb iT邦好手 1 級 ‧ 2016-12-27 08:33:56 檢舉

我剛剛取得 gmail 應用程式密碼,再用程式透過 gmail 587 port 寄信就成功了。

0
huowang99
iT邦新手 5 級 ‧ 2016-12-26 08:59:56

因為您提供的資訊有限,建議

  1. 找2台不同的設備,在相同或不同的網路下做帳號測試
  2. 確定您的SMTP設定是否無誤,例如是否勾選驗證等等
  3. 請檢查gmail裡的安全性設定,將 允許安全性較低的應用程式存取您的帳戶 開啟,不然您的收信軟體可能是無法使用的。
sodoi iT邦新手 5 級 ‧ 2016-12-26 09:09:04 檢舉

我有 A,B,C 三部電腦, A 與 B 在甲地, C 在乙地.
甲乙兩地的 ISP 不同.
甲地使用中華電信 4G 網路也不通.
gmail 的 "允許安全性較低的應用程式存取您的帳戶" 都有開啟.
三部 telnet smtp.gmail.com 465 都無回應.

SMTP Server: smtp.gmail.com
SMTP port: 465
SMTP requires SSL: yes
SMTP requires Authentication: yes
gmail 的帳號密碼都確認過了.

若使用 yahoo 的 smtp server (smtp.mail.yahoo.com), 465 也不通.

huowang99 iT邦新手 5 級 ‧ 2016-12-26 11:22:56 檢舉

剛有測試 確定設定smtp.gmail.com ssl:465 勾選驗證 是OK的,可以正常收發信。

再請問您的ISP是中華嗎?有的非中華的ISP會鎖SMTP造成無法發信,要詢問看看。

另外若您的線路是中華的,您也可以嘗試將SMTP 設定為中華的msa.hinet.net試試

我自己常遇到的不能收發,通常是"允許安全性較低的應用程式存取您的帳戶" 這個沒開。而且常常會明明設定了開啟,在次登入檢查時變關閉,要多開幾次.....

至於telnet smtp.gmail.com 465 我不確定這樣的方式是否正確...
因為Telnet 是可以在防火牆上封鎖的。

0
SophiaH
iT邦見習生 0 級 ‧ 2017-05-20 20:22:24

不好意思, 我在WP網站 (目前在localhost本機測試)安裝 WP-mail-SMTP外掛, 用Gmail SMTP 寄測試信, (已在php.ini打開 ssl), 但出現以下訊息 :

2017-05-20 12:15:47 Connection: opening to ssl://smtp.gmail.com:465, timeout=300, options=array ( )
Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\wordpress\wp-includes\class-smtp.php on line 1149

請問還應如何修改設定 ? 這個檔的第1149行相關內容如下 :
protected function errorHandler($errno, $errmsg) {
$notice = 'Connection: Failed to connect to server.';
$this->setError(
$notice,
$errno,
$errmsg
);
$this->edebug(
$notice . ' Error number ' . $errno . '."Error notice: '. $errmsg,
self::DEBUG_CONNECTION
);
}
謝謝

我要發表回答

立即登入回答