iT邦幫忙

0

已解決. CIDR class c

https://ithelp.ithome.com.tw/upload/images/20180111/20108271c5DVMfMNnt.jpg

想了兩天看沒有 有人可以幫我解答嗎 ?
他這樣 只有160台 要怎算

看更多先前的討論...收起先前的討論...
Class C 那題 就是切最小網段大小
1 => 64
2 => 128
3 => 8
4 => 8
5 => 16
6 => 32
剛好等於 256,至於 CIDR 起始IP 跟 號碼,自己查
CISCO 的語法,自己看書然後組織,這些都是CCNA 必考
轉不太過來 起使 192.168.16.1
那他用 195.33.20..? 不懂
我是自學的 所以... 零零散散
黃彥儒 iT邦研究生 3 級 ‧ 2018-01-11 10:20:44 檢舉
那有沒有考慮上課呢?
有考慮 現在在實習還有沒時間上課..
那第一題是
195.33.20.0/60 只要改後面台數嗎?
195.33.20.0/20
195.33.20.0/80
195.33.20.0/240
195.33.20.0/200
195.33.20.0/40
1.(195.33.20.15/24
2.(195.33.20.25/24
3.(195.33.20.18/24
4.(195.33.20.35/24
5.(195.33.20.5/24
6.(195.33.20.10/24
第一題這樣對嗎?
丹尼 iT邦研究生 4 級 ‧ 2018-01-11 11:37:33 檢舉
網路上有解答吧
第一題已經有高手解答我就不多說了
第二題
三台router 都要設定基本資訊
只有DCE要設定clock (有些router有預設 通常我會改掉)

R1:
interface FastEthernet0/0
ip address 172.30.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0/0
ip address 209.165.200.229 255.255.255.252
router ospf 100
log-adjacency-changes
network 172.30.1.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.3 area 0
network 209.165.200.228 0.0.0.3 area 0
----------------------------------------------------------------------------------------
R2:
interface FastEthernet0/0
ip address 10.1.0.1 255.255.0.0
duplex auto
speed auto
!
interface Serial0/0/0
ip address 209.165.200.230 255.255.255.252
clock rate 64000
!
interface Serial0/0/1
ip address 209.165.200.233 255.255.255.252
clock rate 64000
router ospf 100
!
log-adjacency-changes
network 10.1.0.0 0.0.255.255 area 0
network 209.165.200.228 0.0.0.3 area 0
network 209.165.200.232 0.0.0.3 area 0
----------------------------------------------------------------------------------------
R3:
interface FastEthernet0/0
ip address 172.30.100.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.10.2 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/0/1
ip address 209.165.200.234 255.255.255.252
!
router ospf 100
log-adjacency-changes
network 209.165.200.232 0.0.0.3 area 0
network 172.30.100.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.3 area 0
!
魷魚 iT邦新手 2 級 ‧ 2018-01-11 17:12:35 檢舉
第一題還有什麼問題?窮嘶大已經寫出正確答案了還要問什麼= ="
另外來問功課答案已經很瞎了,問完還把標題跟問題改掉的心態也是奇葩
對不起

2 個回答

0
yesongow
iT邦大師 1 級 ‧ 2018-01-11 22:03:27

IPv4就只有32bit長,頂多就是195.33.20.x/32

哪有195.33.20.0/240 這種 /240的啦?

看更多先前的回應...收起先前的回應...
yesongow iT邦大師 1 級 ‧ 2018-01-11 22:11:09 檢舉

Class C 那題 就是切最小網段大小
網路遮罩 255.0.0.0 =/8
網路遮罩 255.255.0.0 =/16
網路遮罩 255.255.255.0 =/24
這種表示方式,satonew1996你應該看的懂,且能互相轉換,沒有問題吧?

/24,代表一個Class C,也是256個IP (從0到255)
當你有100台電腦要在同一個網段時,剛好可以用255.255.255.128來切 割網路,將256個IP分成兩個128IP,0..127與128..255
看你想用哪一個都行!
所以(2)的答案有兩種,二選一吧!
195.33.20.0/25,或是195.33.20.128/25

yesongow iT邦大師 1 級 ‧ 2018-01-11 22:15:51 檢舉

再來第二多的電腦數量是30台,實際上需要的不止30個IP,還要subnet與Brocast,及GW,所以合計要33個IP
所以,你不能將30台電腦放在/27的網段內,因為/27僅有32個IP
這時候,30台電腦必須放在/26的網段內,因為/26有64個IP

yesongow iT邦大師 1 級 ‧ 2018-01-11 22:18:20 檢舉

當你(2)的答案是195.33.20.0/25時
代表195.33.20.0-195.33.20.127,已經用掉了
剩下的範圍就是195.33.20.128-195.33.20.255

所以,(1)的答案會有兩種,195.33.20.128/26,或是195.33.20.192/26

yesongow iT邦大師 1 級 ‧ 2018-01-11 22:21:21 檢舉

當你(2)的答案是195.33.20.128/25時
代表195.33.20.128-195.33.20.255,已經用掉了
剩下的範圍就是195.33.20.0-195.33.20.127

所以,(1)的答案會有兩種,二選一吧!
195.33.20.0/26,或是195.33.20.64/26

yesongow iT邦大師 1 級 ‧ 2018-01-11 22:33:56 檢舉

所有的答案,會因為(2)用掉,及(1)用掉後,所剩下的網段來變化!
所以,若是這是考試,可別抄寫隔壁同學的答案,這樣容易被抓包!

良心的推薦,由多的電腦先分配,從0開始分配!
100台電腦(2),網段大小為128個IP,故選用195.33.20.0/25
30台電腦(1),網段大小為64個IP,故選用195.33.20.128/26
20台電腦(6),網段大小為32個IP,故選用195.33.20.192/27
10台電腦(5),網段大小為16個IP,故選用195.33.20.224/28
專線互連(3),網段大小為4個IP,故選用195.33.20.240/30
專線互連(4),網段大小為4個IP,故選用195.33.20.244/30

未來專線A擴充(?),網段大小為4個IP,故選用195.33.20.248/30
未來專線B擴充(?),網段大小為4個IP,故選用195.33.20.232/30

如果(3)與(4)的網段使用8個IP,代表/29囉!

0
Daniel
iT邦新手 5 級 ‧ 2018-01-12 15:23:54

沒有用到的可用ip 就 不管它 保留起來 把160台補滿就好~

網段遮罩

255.255.255.0=/24

255.255.255.128=/25 ,( 256-128 =128 (每一段IP總數,包括網路位置+廣播位置))
255.255.255.192=/26 ,( 256-192 =64 (每一段IP總數,包括網路位置+廣播位置))
255.255.255.224=/27 ,( 256-224 =32 (每一段IP總數,包括網路位置+廣播位置))
255.255.255.240=/28 ,( 256-240 =16 (每一段IP總數,包括網路位置+廣播位置))
256個IP位置
子網段切割為樹狀圖
IP位置 1段 /24 可分為 2段/25
0~127用掉 剩下128~255可以劃分出來 (網路位置為該段第一位 廣播為該段最後一位
(0~127解釋 , 0為網路位置 127為廣播位置))
/25 可分為 2段 /26
/26 可分為 2段 /27
以下推算相同原理可以推算

計算每一段,有使用過就列為使用中的一段
請用模擬器試試 XD

以上提供的知識若有誤 再請糾正指導 謝謝~

我要發表回答

立即登入回答