iT邦幫忙

0

在CentOS 升級openssl到1-1.1.0g

這幾天去爬了些文章,網路上有提供很多很詳細的資料幫助升級。

在升級openssl的過程中發現在修補該錯誤的過程中
openssl: error while loading shared libraries: libssl.so.1.1: cannot open shared object file: No such file or directory

正要做這個動作
ln -s /usr/local/lib64/libssl.so.1.1 /usr/lib64/libssl.so.1.1
得到
ln: creating symbolic link ‘/usr/lib64/libssl.so.1.1’: 沒有此一檔案或目錄

去查一下系統版本發現核心版本是2.6.32-696.16.1.el6.i686
其他臺在升級過程中沒問題的機器版本是2.6.32-696.16.1.el6.i686.x86_64

後來爬了數天文章還是沒有頭緒,請問各位前輩這個狀況能怎麼解決?

看更多先前的討論...收起先前的討論...
froce iT邦大師 3 級 ‧ 2018-05-01 19:29:13 檢舉
去 /usr/local/lib下看看有沒有libssl.so.1.1 ?
weiclin iT邦高手 4 級 ‧ 2018-05-01 22:14:07 檢舉
看這兩個目錄是否存在, 沒有的話自己建立目錄
/usr/local/lib64
/usr/lib64
snameless iT邦新手 5 級 ‧ 2018-05-06 08:33:17 檢舉
抱歉現在才看到,我試試看!
snameless iT邦新手 5 級 ‧ 2018-06-01 17:14:19 檢舉
這部份已經整理好了:
ln -s /usr/local/lib/libssl.so.1.1 /usr/lib/libssl.so.1.1
ln -s /usr/local/lib/libcrypto.so.1.1 /usr/lib/libcrypto.so.1.1
改做這兩個就可以了,真抱歉現在才發

尚未有邦友回答

立即登入回答