iT邦幫忙

0

amazon linux ami 安裝php72錯誤

php

Amazon Linux AMI 2018.03 這樣的版本
在裝epel-release 或remi時到底要裝6版還是7版?
我在試著裝php7時會遇到yum install時有抓到
但是會抓到amzn發布的php53的舊版,就算把amzn強制關閉了
在安裝php7時還是會一直出錯
比方說
Error: Package: php-fpm-7.2.5-1.el7.remi.x86_64 (remi-php72)
Requires: systemd-sysv
Error: Package: php-fpm-7.2.5-1.el7.remi.x86_64 (remi-php72)
Requires: libsystemd.so.0(LIBSYSTEMD_209)(64bit)
Error: Package: php-7.2.5-1.el7.remi.x86_64 (remi-php72)
Requires: httpd-mmn = 20120211x8664
Installed: httpd24-2.4.27-3.75.amzn1.x86_64 (@amzn-main)
httpd-mmn = 20120211
httpd-mmn = 20120211x86-64
Error: Package: php-fpm-7.2.5-1.el7.remi.x86_64 (remi-php72)
Requires: systemd
Error: Package: php-fpm-7.2.5-1.el7.remi.x86_64 (remi-php72)
Requires: libsystemd.so.0()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

在Amazon Linux AMI到底要怎麽處理這些相容性問題

尚未有邦友回答

立即登入回答