iT邦幫忙

0

Android min版本 與 compile版本和support library的問題

假設我今天使用compilesdk使用28 然後minsdk使用15

是不是代表我可以用sdk28的環境編譯出最小能在15版本使用的app

但如果出現了在api 28裡面的某些功能,沒辦法支援15

是不是編譯的時候會直接報錯呢,因為他為了你編出來的app能在15執行?

意思是我即使用sdk 28的環境寫app,但只能用api 15能支援的東西,我這樣理解是對的嗎?

但andorid不是有提供support library,比如我import了support v7,不是能提供函式最小到v7都能支援嗎?

不好意思,因為看了很多文章,還是覺得android開發時版本之間的兼容關係很複雜,所以語言組織的不太好,請見諒,看得懂我疑問的大大們希望能回答

1 個回答

0

是不是代表我可以用sdk28的環境編譯出最小能在15版本使用的app

minsdk代表的是你所用的最低sdk等級 同時也代表限制最低sdk版本的手機
舉例 : 使用15對應的是4.0.3的版本以上手機
如果你限制到26 那同時也代表只有8.0以上的手機可以安裝該app

是不是編譯的時候會直接報錯呢,因為他為了你編出來的app能在15執行?

如果你使用特定功能高於minsdk等級時 ide會有紅線警告你sdklevel不足
此時該類型運作不理會警告時則會閃退

比如我import了support v7,不是能提供函式最小到v7都能支援嗎?

是的
Android的support library是向上兼容的vn代表 : n以上版本都可以使用與支援
v7已經低於Android2.3

個人見解 如果有誤 請告知更正

我要發表回答

立即登入回答