iT邦幫忙

0

LINE Chatbot heroku上傳失敗 錯誤H10 且網頁無法找出

我跟著米大的chatbot步驟做 一路上雖然有許多錯誤
都還能解決 但這次我實在沒有頭緒
上傳後網頁無法被找尋到 在做了很多修正 最終導致連本機伺服器都無法找出
原文:
https://ithelp.ithome.com.tw/users/20107309/ironman/1253

錯誤訊息:
https://d1dwq032kyr03c.cloudfront.net/upload/images/20181102/20110243fBnYxqUT6T.png

https://d1dwq032kyr03c.cloudfront.net/upload/images/20181102/20110243z1LRc9e6UV.png
https://d1dwq032kyr03c.cloudfront.net/upload/images/20181102/20110243z1LRc9e6UV.png

-----> Ruby app detected
-----> Compiling Ruby/Rails
-----> Using Ruby version: ruby-2.4.4

WARNING:
Removing Gemfile.lock because it was generated on Windows.
Bundler will do a full resolve so native gems are handled properly.
This may result in unexpected gem versions being used in your app.
In rare occasions Bundler may not be able to resolve your dependencies at all.
https://devcenter.heroku.com/articles/bundler-windows-gemfile
-----> Installing dependencies using bundler 1.15.2
Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4
The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x86-mswin32, x64-mingw32, java. To add those platforms to the bundle, run bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java.
Fetching gem metadata from https://rubygems.org/..........
Fetching version metadata from https://rubygems.org/..
Fetching dependency metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 12.3.1
Using concurrent-ruby 1.0.5
Using minitest 5.11.3
Using thread_safe 0.3.6
Using builder 3.2.3
Using erubi 1.7.1
Using mini_portile2 2.3.0
Using crass 1.0.4
Using rack 2.0.5
Using nio4r 2.3.1
Using websocket-extensions 0.1.3
Using mini_mime 1.0.1
Using arel 9.0.0
Using mimemagic 0.3.2
Using msgpack 1.2.4
Using bundler 1.15.2
Using coffee-script-source 1.12.2
Using execjs 2.7.0
Using method_source 0.9.0
Using thor 0.20.0
Using duktape 2.0.1.0
Using ffi 1.9.25
Using multi_json 1.13.1
Using pg 0.21.0
Using puma 3.12.0
Using rb-fsevent 0.10.3
Using tilt 2.0.8
Using turbolinks-source 5.2.0
Using i18n 1.1.1
Using tzinfo 1.2.5
Using nokogiri 1.8.5
Using rack-test 1.1.0
Using sprockets 3.7.2
Using websocket-driver 0.7.0
Using mail 2.7.1
Using marcel 0.3.3
Using bootsnap 1.3.2
Using uglifier 4.1.19
Using coffee-script 2.4.1
Using rb-inotify 0.9.10
Using activesupport 5.2.1
Using turbolinks 5.2.0
Using loofah 2.2.3
Using rails-dom-testing 2.0.3
Using globalid 0.4.1
Using activemodel 5.2.1
Using jbuilder 2.7.0
Using sass-listen 4.0.0
Using activejob 5.2.1
Using rails-html-sanitizer 1.0.4
Using activerecord 5.2.1
Using actionview 5.2.1
Using actionpack 5.2.1
Using sass 3.6.0
Using actioncable 5.2.1
Using actionmailer 5.2.1
Using activestorage 5.2.1
Using railties 5.2.1
Using sprockets-rails 3.2.1
Using coffee-rails 4.2.2
Using rails 5.2.1
Using sass-rails 5.0.7
Bundle complete! 17 Gemfile dependencies, 62 gems now installed.
Gems in the groups development and test were not installed.
Bundled gems are installed into ./vendor/bundle.
Bundle completed (3.46s)
Cleaning up the bundler cache.
The latest bundler is 1.17.1, but you are currently running 1.15.2.
To update, run gem install bundler
-----> Installing node-v8.10.0-linux-x64
-----> Detecting rake tasks
-----> Preparing app for Rails asset pipeline
Running: rake assets:precompile
Yarn executable was not detected in the system.
Download Yarn at https://yarnpkg.com/en/docs/install
Asset precompilation completed (1.11s)
Cleaning assets
Running: rake assets:clean
-----> Detecting rails configuration

WARNING:
Removing Gemfile.lock because it was generated on Windows.
Bundler will do a full resolve so native gems are handled properly.
This may result in unexpected gem versions being used in your app.
In rare occasions Bundler may not be able to resolve your dependencies at all.
https://devcenter.heroku.com/articles/bundler-windows-gemfile
WARNING:
Detecting rails configuration failed
set HEROKU_DEBUG_RAILS_RUNNER=1 to debug
WARNING:
We detected that some binary dependencies required to
use all the preview features of Active Storage are not
present on this system.

For more information please see:
https://devcenter.heroku.com/articles/active-storage-on-heroku

WARNING:
No Procfile detected, using the default web server.
We recommend explicitly declaring how to boot your server process via a Procfile.
https://devcenter.heroku.com/articles/ruby-default-web-server
-----> Discovering process types
Procfile declares types -> (none)
Default types for buildpack -> console, rake, web
-----> Compressing...
Done: 43.2M
-----> Launching...
Released v7
https://people-all-lovel-jeanne.herokuapp.com/ deployed to Heroku

程式碼設定:https://ithelp.ithome.com.tw/upload/images/20181105/20110243ruJTsNA0G0.pnghttps://ithelp.ithome.com.tw/upload/images/20181105/201102438j6JKcSLwc.pnghttps://ithelp.ithome.com.tw/upload/images/20181105/20110243aWUHvlmfrp.png

尚未有邦友回答

立即登入回答