iT邦幫忙

0

舊設備上的設定2960 10/100
interface FastEthernet0/23
duplex full
port group 1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-4,132,133,1002-1005
switchport mode trunk
!
interface FastEthernet0/24
duplex full
port group 1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-4,132,133,1002-1005
switchport mode trunk
我將設定要改設定到最近新購的2960 10/100/1000 48PORT
要將兩台舊的2960設定轉移至新的設備但是在TRUNK PORT上
!
interface GigabitEthernet0/47
switchport trunk allowed vlan 1-4,132,133,1002-1005
switchport mode trunk
!
interface GigabitEthernet0/48
switchport trunk allowed vlan 1-4,132,133,1002-1005
switchport mode trunk
新設備上發現
無法設定
switchport trunk encapsulation dot1q

可用模式
Enter configuration commands, one per line. End with CNTL/Z.
2960L(config)#int
2960L(config)#interface g
2960L(config)#interface ga
2960L(config)#interface GigabitEthernet0/46
2960L(config-if)#ch
2960L(config-if)#channel-gr
2960L(config-if)#channel-group 1 mo
2960L(config-if)#channel-group 1 mode ?
active Enable LACP unconditionally
auto Enable PAgP only if a PAgP device is detected
desirable Enable PAgP unconditionally
on Enable Etherchannel only
passive Enable LACP only if a LACP device is detected

2960L(config-if)#channel-group 1 mode

2960L(config-if)#sw
2960L(config-if)#switchport tr
2960L(config-if)#switchport trunk ?
allowed Set allowed VLAN characteristics when interface is in trunking mode
native Set trunking native characteristics when interface is in trunking
mode
pruning Set pruning VLAN characteristics when interface is in trunking mode

bibipolo iT邦新手 5 級 ‧ 2020-03-02 10:50:14 檢舉
補充 我目前這樣設定 接再2960L VLAN1 我可以 PIN自己與CORE 也可以 TELNET 自己與CORE 但是我改接再CORE的VLAN1 無法PING 2960L也無法TELNET到2960L
我在想是因為新設備無法設定
switchport trunk encapsulation dot1q 不知是否有變通的設定方式

1 個回答

0
補覺鳴詩
iT邦研究生 4 級 ‧ 2020-03-02 14:23:59
最佳解答

channel-group 設定完後
會成為一個邏輯的 interface
設定會吃個 邏輯 interface

而原本的 interface 設定大部分會被忽略
包含 trunk

所以設定應該是如此
舊的 switch

在 config mode 


interface range FastEthernet0/23-24
port group 1
exit

interface port group 1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-4,132,133,1002-1005
switchport mode trunk
exit

新的 switch

interface range GigabitEthernet0/47-48
channel-group 1 mode auto
exit

interface channel-group 1  
switchport trunk allowed vlan 1-4,132,133,1002-1005
switchport mode trunk
exit

韌體不一樣
語法會稍微不同
請再自行看官方文件轉一下

bibipolo iT邦新手 5 級 ‧ 2020-03-02 21:50:28 檢舉

謝謝 我再來試一下

我要發表回答

立即登入回答