iT邦幫忙

0

chrome:要開啟這個應用程式警告視窗,如何允許而不再跳出

您好:
請問 因為使用URL PROTOCAL (或稱 aunching applications using custom browser protocols)
WEB會呼叫 本機的 XXX.exe

每次執行時,都會跳出該視窗
請問,是否有方式可以默認他不要再跳出。
我有去過內容\ 通知 或 彈出視窗與重導向

因為 WEB呼叫 URL protocal 的方式為 XXX://hello...
但通知 或 彈出視窗與重導向,只能讓我輸入 XXX

就算出設定了,他仍會跳出。

也有去找到

1.	Have Chrome version > 79
2.	Run the following command in terminal 
3.	defaults write com.google.Chrome ExternalProtocolDialogShowAlwaysOpenCheckbox -bool true
4.	Quit Chrome
5.	Restart Chrome

但defaults 不是內部指令...

或 修改 %localappdata%\Google\Chrome\User Data\Default\ and open the Preferences
但,他又會變回原來設定

謝謝!

1 個回答

0
浩瀚星空
iT邦超人 1 級 ‧ 2020-06-29 14:45:15

基本上,你找的這個設定值。

ExternalProtocolDialogShowAlwaysOpenCheckbox

只是幫你開啟「一律開啟」的核取框。預設值我記得本來就是開的。
當會員有勾選後,才會在下一次不在問。

也就是說,還是一定會至少問一次。

不過具小道消息,google有意將其改成預設值是關的。
也就是不讓會員有機會可以「持續允許」的作用。

現在是開的還是關的我沒研究。

你可以往這方面去加油一下。基本上我是誠心告訴你。
只要是動到本機應用的,都很麻煩的。
再加上安全性的加強。就算現在真有辦法可以用了。
也難保未來就不能用。
詳細可參考早期flash模式下可操控本機的方式
現在當然都不能了。但google還是防不勝防。所以有意直接禁用flash了。

現在在開發都會盡量不要依本機運行的方式。免得未來踩雷踩的很痛苦。

froce iT邦大師 1 級 ‧ 2020-06-29 14:48:16 檢舉

該建議的都建議了,真的不會弄web service的話建議外包了。

noway iT邦新手 5 級 ‧ 2020-06-29 22:08:37 檢舉

您好:謝謝您的建議,會找時間學GO 與 web service。只想說目前遇到的問題,看有沒有得解決!

想自動是無解啦!!只能這樣跟你說。

我要發表回答

立即登入回答