iT邦幫忙

0

【已解決】CentOS 7 安裝 KVM 搭建 Win10

安裝 Win10 出現了這畫面:
https://ithelp.ithome.com.tw/upload/images/20200728/201248500Mr9swnrhW.png

試過進入 oobe 這個解決方式也無法解決;在安裝其他 Linux 操作系統時,基本上不會有問題,很順利安裝完進入畫面並且開始使用。

操作系統是 CentOS 7 ,最近在學習 KVM 這塊,但目前爬到的文章似乎都不太有幫助,或是我漏看了什麼,實際上以命令模式安裝 Win10 的文章幾乎不詳細,或是很久遠,請問有最新的 KVM 搭建 Win10 的相關文章能提供我參考嗎?且必須以命令模式操作的

這是我安裝時操作的命令:

qemu-img create -f qcow2 /home/kvm/win.qcow2 50G
virt-install --virt-type kvm --name win --vcpu 4 --ram 4096 --disk /home/kvm/win.qcow2,format=qcow2 --network network=default --graphics vnc,listen=0.0.0.0,password=my_passwd --noautoconsole --os-type=Microsoft --os-variant=win10 --cdrom=/home/Win10_x64.iso

1 個回答

1
japhenchen
iT邦大師 1 級 ‧ 2020-07-28 16:24:35

我是在ubuntu 19.10 server上架設了headless VirtualBox6+vbox-server+phpvirtualbox做網頁管理,省去了步步都要用cli的麻煩(懶出翔了),而且幾乎什麼作業統都能動(還蠻快的)

https://ithelp.ithome.com.tw/upload/images/20200728/20117954tlCbZomduF.jpg

看更多先前的回應...收起先前的回應...
企鵝 iT邦新手 5 級 ‧ 2020-07-28 16:43:29 檢舉

感謝您的回答
在 virtualbox 中搭建win是沒問題,但這次主要是透過KVM來搭建,這篇文章我看過,我還是傾向使用命令來達到目的

不㧵道是不是半虛擬化的支援沒開啟所致

企鵝 iT邦新手 5 級 ‧ 2020-07-28 17:07:06 檢舉

虛擬化支持以開啟,我用 KVM 嘗試安裝了 ubuntu16、ubuntu18 皆能正常使用,但在安裝 Win10 就遇到了這個問題不知道如何去解決,查了許多文章但都無法成功,可能文章也久了

雷伊 iT邦好手 1 級 ‧ 2020-07-28 18:00:41 檢舉

企鵝
你是否安裝了Win10 2004挑BIOS版?只要BIOS太舊就死給你看

企鵝 iT邦新手 5 級 ‧ 2020-07-28 18:28:02 檢舉

問題已解決,謝謝各位

是VT-d半虛擬化的設定相關嗎?

企鵝 iT邦新手 5 級 ‧ 2020-07-29 15:18:01 檢舉

效能分配的問題,突然一個想法想到會不會是效能,所以按照原作法是沒問題的,搞錯方向

RAM給太少哦?

企鵝 iT邦新手 5 級 ‧ 2020-07-31 18:25:11 檢舉

很抱歉現在才回復,前兩天這裡的登入壞了

不知道是不是CPU全給的關係(感覺不出來),調降 CPU 後就沒問題了

我要發表回答

立即登入回答