iT邦幫忙

0

關於安裝Windows Server 2008 遇上的疑難雜症求解

bxun 2021-05-25 03:06:201005 瀏覽

求助,謝謝。

電腦規格
ASUS K31CD - 三年前買的套裝機 (Windows 10 家用版)
CPU:I5-7400
顯示卡:GT720
主機板:K31CD-K
系統SSD硬碟:PH5-CE120
資料HDD硬碟:TOSHIBA DT01ACA100

Windows Server 2008:朋友給的兩片安裝光碟

情況:

  1. 使用外接光碟機讀取Windows Server 2008光碟,電腦偵測的到硬碟機存在,但沒辦法讀取安裝程式

  2. 光碟無法使用後,改成燒錄至USB內安裝,一樣是電腦偵測得到USB存在,但沒辦法讀取安裝資料

  3. 機殼上所有的插孔,USB2.0跟USB3.0的我都測試過了,依然是可以偵測,但無法讀取

  4. 改用VM虛擬機安裝,測試ISO是否有毀損,最後是可以安裝的,ISO沒有問題

  5. 改用第二張Windows Server 2008光碟嘗試看看,情況跟前五步一樣

  6. 想說直接在Windows 10 系統內開啟安裝程式,來安裝Windows Server 2008到HDD硬碟上,我把HDD改成MBR格式後,是可以打開安裝程式,但最後顯示這個 (7)

  7. https://ithelp.ithome.com.tw/upload/images/20210524/20132457h4r7mqJG7s.png

  8. 改用筆電測試 (型號:Lenovo ThinkPad T430S)

  9. Windows Server 2008光碟無法讀取

  10. 改用USB安裝,可以讀取,但....直接在讀取階段就卡死,等了三十分鐘,完全不動。

  11. 再換媽媽的電腦來試試看,這次可以進入安裝程式,但卻顯示「遺失必要的CD/DVD驅動程式」以及「找不到裝置驅動程式,請確定安裝媒體包含正確的驅動程式」

最後:
好,目前我無計可施了,麻煩各位高手賜教,我這兩台電腦與筆電該如何安裝Windows Server 2008?

我朋友是告訴我可以嘗試用虛擬機安裝後,再複製到硬碟內來完成安裝,有人知道該怎麼做嗎? (朋友賣關子不講@@)

看更多先前的討論...收起先前的討論...
你怎麼什麼都懷疑了,就是不懷疑朋友給的2008是不是有問題?
bxun iT邦新手 5 級 ‧ 2021-05-25 07:59:59 檢舉
我用VM測試安裝ISO是可以安裝成功的@@
開機瘋狂按DEL或F2(不是一直按著)進BIOS,然後開BOOT PRIORITY(開機順序),每一家的BIOS畫面及放的位置都不同,請..........拍畫面來


重點是,學裝機怎會不懂BIOS?
2008的版本是不是R2?
bxun iT邦新手 5 級 ‧ 2021-05-25 09:12:09 檢舉
BIOS的開機順序我都有改過,其他設定我就不確定我是否改動正確。 光碟不是R2
2008 跟 WIN 7 一樣不吃UEFI,如果要用UEFI開機,要先 MBR 開機之後,用 DISKPART 建立 GPT 分割區,接著用 DISM 部屬,然後再修正 BCD之後就行了
但是 DISKPART 跟 DISM 建議用更高版本的來處理,我一般乾脆直接拆下硬碟拿到 WIN10的環境,部屬好 2008 再接回來開機,大致上是這麼操作
還有 要記得用 DISM 補上SATA 的 2008 驅動,個人懷疑七代主板的SATA 在 2008 原生不支援

突然發現樓主是 七代主板,個人只能說幾乎不可能有 2008 的驅動,因為七代主板原生不支援 WIN 7 / 2008,除非晶片剛好有開WIN 7 驅動才有機會
建議是用虛擬機跑 2008 就好,不用想太多,不管是不是R2,都沒用
bxun iT邦新手 5 級 ‧ 2021-05-25 11:49:51 檢舉
喔,對........七代主機板不支援,不過我的筆電是五代CPU,系統用的是WIN7,所以跑的了安裝程式,但卻會卡在讀取畫面,這部分有解嗎? 謝謝。
你 CPU 也是 七代的啊 ... ,I5 7 代,基本上要硬上,就是要先用 DISM 掛載之後去合併必要的驅動 USB 3 、 SATA,主要是這兩個,如果是光碟安裝那SATA驅動是必要的,掛載驅動之後才能正常裝,我都是嫌麻煩,直接用 DISM釋放映像,然後修正開機導引,接著塞必要的驅動,USB 3 SATA LAN ,大概就這樣,我主要的外接OS是WIN 10 WTG,所以基本上一定吃7-10代主板,但11代要補 LAN,尤其是11代 5系列晶片LAN 都 2.5G 了,WIN 10 內建不吃,要另外載入,更不要說 NVME 在 11代 MBR幾乎無法開機,必須走 UEFI了
bxun iT邦新手 5 級 ‧ 2021-05-27 09:54:24 檢舉
好,感恩,我研究一下你教的方法。

1 個回答

0
補覺鳴詩
iT邦高手 1 級 ‧ 2021-05-25 07:54:43

你的 ISO 是從目前手上的光碟建立的嗎 ?
如果是
那 8 成只是你 BIOS 要改設定

bxun iT邦新手 5 級 ‧ 2021-05-25 07:56:18 檢舉

對,是光碟建立,那請問要改哪些設定?

比如說 UEFI BOOT 、 Secure Boot
暫時先關掉 讓他先用 legcy mode 開機
boot order 改一下

bxun iT邦新手 5 級 ‧ 2021-05-25 11:45:37 檢舉

好,我再試試看,謝謝

我要發表回答

立即登入回答