iT邦幫忙

5

在 CentOs 5 設定 PPPoE上網以及取得固定IP

wolf 2010-01-03 01:35:0816401 瀏覽

Loverhouse站長日誌
最近因為要架設一個商業網站,所以把公司報廢的電腦搬回家,經過整理與更換零件,總算資源回收再利用成功!
選了兩種Linux版本來當伺服器軟體 :1. Fedora Core 9 | 2.CentOS 5, 經過一週來的安裝與測試,我發現兩套OS都很棒,我以前也試用過Fedora系列,安裝CentOS還是第一次,所以我決定就安裝 CentOS 5 來做為這次網站的伺服軟體。

當我安裝完成後,問題來了?無法連接網路,當然,也無法取得固IP了,這點很重要!網站要能夠被找到,固IP必須能夠被主機取得,這樣才可以讓網站正式運作,是了N次後,決定到網路上找救兵!我用另一部winxp主機上網,寫到這裡,我要推薦幾個很優質的論壇,這次都靠這些前輩,我才可以解決問題!
1.IT邦幫忙 - 一個對於經驗較淺的人而言,這裡絕對可以找到答案
2.資安論壇 - 行政院國家資通安全會報 技術中心
3.工程師碎碎唸 - 很NICE的個人部落格喔!
當然,在網路上還有許多優質的討論區,大家可以上去搜尋搜尋吧!

讓我言歸正傳:
最後我終於解決這個問題,所以把它PO出來,大家研究研究

1.完成安裝後,進入文字指令(終端機系統)版面,key入下列文字:
root@www~> /usr/sbin/adsl-setup
然後依據文字引導輸入內容,這裡要特別注意一點,就是要求輸入ISP給您的帳號時,如果您是HiNet用戶,格式是 XXX@hinet.net ; 如果您是 seednet 用戶,則 帳號輸入格式 Txxxxxxx#,記得後面加上 # 很重要喔!(因為您若沒有輸入 # 符號,您就無法取得ISP提供的固定IP);密碼要輸入ISP業者給您的撥接登入密碼。
2.輸入DNS Server IP, 您必須向您的ISP業者詢問DNS IP, 如果您有申請網域名稱,可以在ISP業者網域名稱管理網站裡得到這2組IP喔~
3.接下來要注意的是, 依照文字引導填入所需資料。

我照這樣填寫完畢後, 查看系統, 是已經建立了 PPPoE狀態, 可是問題卻沒有解決,也就是無法撥接上網??

經過連番嘗試, 我終於發現問題了, 這真是讓我哭笑不得, 於視覺得應該記錄下來:

滑鼠移至視窗左下方點選 "系統"->網路;開啟網路設定視窗後,點選ppp0->編輯,看到設定框,將DHCP下方文字 "由ISP業者提供DNS"這個選項打ˇ,然後存檔->重新開機。

完成這個步驟後,我重新開機,太棒了~開機就自動上網了,我用文字模式 "ping www.loverhouse.tw" 確實對應到我的固定IP了,接下來幾天,我每天都做重新開機與對應IP測試,都沒問題了!

把這個經驗提供出來,希望對大家有幫助!!


1 則留言

0
Blue Jacky
iT邦大師 1 級 ‧ 2012-12-31 12:29:46

若客觀修件許可
還是建議將 CentOs 5.8 換成 6.3
否則因為套件關係
許多網站內容功能都不能用

jacky1122提到:
修件許可

更正:條件許可

wolf iT邦新手 5 級‧ 2014-09-12 15:48:56 檢舉

我現在升到7.0,還是碰到網路設定問題~快瘋了

我安裝CENTOS 7.0 後,網路不能啟動
以文字模式設定網卡,IP後,重新啟動依舊無法啟動,我敘述一下
1: 我的電腦原先是安裝Win XP系統, 應該是X86_32bit系統, 2G RAM , 150G HD; 現在則安裝CENTOS7.0系統(原WINXP就洗掉了)
2. 安裝CENTOS 7.0 時,就預先設定好網路部分如下:
原網路卡(GIGABIT)被CENTOS7.0設定名稱"enp0s14(Ethernet)"
手動設定->輸入固I位址->輸入NETMASK->輸入GATEWAY->輸入DNS->點選完成
安裝螢幕出現主機與網路->已連線

後續當然就安裝完成->重新啟動囉

結果,開機完成後,網路無法啟動
我檢查網路ISP提供給我的資料如下: 我是pppOE, 有搭配1組固I + 5組浮動IP
之前我有安裝過CENTOS5.0很成功啟動我的伺服器(因我有自行架設網站)
沒想到7.0就不行

我上網查詢到許多前輩大大的文章
於是就依樣畫葫蘆

進入文字模式

DEVICE=eth0

NM_CONTROLLED=no

ONBOOT=yes

BOOTPROTO=static

IPADDR=123.204.51.19 <= seednet給的固I

NETMASK=255.255.255.255

GATEWAY=192.168.0.1

存檔後給他重新啟動
結果=>失敗

反覆殺掉重來,還是失敗

我進:manage connection 視窗哩,把所有安裝時輸入的網路資料都殺掉,重新用文字模式在重建一次

結果=>失敗

我該如何處理?是7.0太新版,我的舊電腦無法相容?還是我哪裡搞錯了呢?

跪請各位大大指導迷津~感謝 :(

我要留言

立即登入留言