iT邦幫忙

2019 iT 邦幫忙鐵人賽

DAY 22
0
Modern Web

Daily UI : 開發者版系列 第 22

Vuetify:Google Fonts › Static Layout

https://codepen.io/hereiscasio/pen/BaBMYEj

Used UI Component ( #1 )

#1 Buttons: Floating action buttons

UI 圖來源見

Discussion

在本日範例中,若你夠細心,可能會發現一個沒列在官方文件中的 API:overflow-x-auto,那我是如何知道有這個 API 呢?我甚至沒上網查,直接測試發現可行就用了。原因很簡單:你只要對 Vuetify 掌握到一定程度,並且真的有搞懂我所謂的 FCC,那它們這個框架開發的脈絡與精神你也會逐漸了解,進而可以輕鬆猜出一些 "隱藏 API"

( 注意目前版本是 2.0.19,當你看到此文章時,他們可能早已補上,然後今天的範例就有使用到此屬性 )事實上這些 API 縱使還沒別列在文件上,影響也不大,但這引出一個議題:「 若一套件處於 y.x 版,到底該不該學/用? 」( 不包括你是該套件的核心開發者,又或是個人時間多到溢出、公司專案就是用套技術的人 )

一般來說,若是中大型的套件,y = 0,我連在 Side Project 上都不敢用,因為做 Side Project 的時間就已經很少了,要是又出一堆問題真是得不償失。若 y = 1,那就要看看 x 是多少,最好 x ≥ 5( 當然這沒有一定,畢竟版號這種東西,不是個絕對的用以判斷到底是否改使用某某套件的最大決策因素 )但要是該套件在市面上只有幾套,也沒有付費版,那管它 y 是多少,可能就還是得嘗試用用看,最糟的情況就是自己寫

y = 1 其實是處在個有點不上不下的階段,這暗示還是可能有機會在開發時,遇到一個該套件的大 Bug,筆者的經驗就是,1.x 的版本開發中大型專案有可能會出問題,若可以的話,一般等到 2.x 或甚至 3.x 最好。那目前 2.x 的官方文件真的足夠完整了嗎?見人見智,至少,簡單的答案就是:對一般新手來說已相當足夠。


上一篇
Vuetify:Google Alert › Advanced Implementation
下一篇
Vuetify:Google Fonts › Advanced Implementation
系列文
Daily UI : 開發者版30

尚未有邦友留言

立即登入留言