iT邦幫忙

0

windows底下VIM有無完美的解決方案

之前有看到網路上一些文章,不過自己試過之後總是多多少少有點問題。

因為有時候要編輯bgi5檔,有些時候要編輯UTF8檔,但是設來設去有時候是編輯有問題,有時是顯示有問題。

我的需求是,開啟時能自動判斷是big5或utf8,並且能正確顯示、編輯、存檔,選單能是中文最好,但如果為了達成上述的目的,用英文的也可以。

請各位大大幫幫忙囉。

wordsmith iT邦高手 1 級 ‧ 2008-08-27 16:19:26 檢舉
因為我用的是命令列模式下的vim(而不是在Windows的圖形介面),之前套用了許多網路上的方式都沒用(後來才想到,其實每個人的版本與作業系統都不一樣,但是寫解決方法的時候,未必會寫清楚,所以才會有大家都說work,就是我不work的現象),今天趁著升級vim 7.2,再試一次,結果就ok了。

我加上的,其實也就是兩行字:

set fileencoding=big5
set fileencodings=utf-8,utf-16,big5

2 個回答

29
fillano
iT邦超人 1 級 ‧ 2008-06-12 00:17:13
最佳解答

我習慣用ultraedit,存檔的時候可以選擇,如果選ansi/ascii那存檔就會是big5,如果選utf-8那就是utf-8等等。

記事本也是一樣,你選ansi存檔就是big5,utf-8就是utf-8。

ultraedit還有一個好處,就是可以用binary的方式檢視檔案,這樣很容易可以根據BOM以及中英文字的binary code判斷檔案實際的編碼是甚麼。

不過這可能沒有完全解決你的問題,因為還是要自己判斷,只是不論big5或是utf-8直接打開編輯都不會有問題就是了。

20
dollarsign
iT邦新手 5 級 ‧ 2008-06-12 13:53:24

VIM 的編碼判斷比 UltraEdit 強太多了,UltraEdit 常常會誤判。
VIM 在選單中選:編輯->Startup Settings
然後會開啟一個設定檔,在設定檔裡加上下面這兩行,啟動時就會自動判斷編碼了。
set fileencodings=utf-8,big5
set fileencoding=big5

我要發表回答

立即登入回答