iT邦幫忙

0

Extreme如何建立trunk

最近正在學習Extreme 450a-48t使用,但是想要建立trunk和另一台cisco串起來,但一直找不到方法,有沒有人使用過Extreme的switch,可以麻煩教學一下,或者是有討論區、教學區可以讓我去觀看。

1 個回答

4
bestken
iT邦新手 1 級 ‧ 2009-08-19 14:41:25
最佳解答

extreme config sample:

<pre class="c" name="code">
create vlan "v101"
configure vlan v101 tag 101
create vlan "v102"
configure vlan v102 tag 102
configure vlan v111 add ports 46 tagged  ;tagged表示用trunk
configure vlan v112 add ports 46 tagged  
configure vlan v101 ipaddress 10.10.10.1 255.255.255.0
enable ipforwarding vlan v101
configure vlan v102 ipaddress 10.10.20.1 255.255.255.0
enable ipforwarding vlan v102

CISCO config sample

<pre class="c" name="code">
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk

將CISCO的 giga-port1 串接到 extreme port 46 ,並使用trunk
而CISCO Vlan ID 101 = Extreme Vlan ID 101 (configure vlan v101 tag "101")

看更多先前的回應...收起先前的回應...
bestken iT邦新手 1 級 ‧ 2009-08-19 14:44:51 檢舉

extreme的重點設定在於
configure vlan v111 add ports 46 tagged ;tagged表示用trunk
configure vlan v112 add ports 46 tagged

我的cisco是2900的機器,我照你寫的去設定,trunk好像還起不來我還是無法ping到對接extreme的那台pc,我們的串法是cisco 2900和exetreme 450a 的port 1 對接,然後cisco port4接pc1,exetreme port4接pc2,cisco我是照你上面寫的把port1 做trunk,只不過我設vlan ip是172.16.1.200/24,exetreme部份我們只用一個vlan,ip是172.16.1.100/24。這樣設定上是有什麼問題嗎?,麻煩指導一下謝謝

順便問一下CISCO 2900是不是只能同時間開啟一個vlan,無法使用二個vlan運作,因為我開一個vlan另外的都會是shutdown,我怎麼no shutdown都是失效。

bestken iT邦新手 1 級 ‧ 2009-08-19 21:21:17 檢舉

目前我知道錯的 cisco有的VLAN,extreme上都要設定!
不介意的話,將CONFIG貼出來給我(遮蔽重要的資訊)
cisco全部 sh run~
extreme只要 sh con vlan~

Extreme-
* X450a-48t.8 # sh con vlan

Module vlan configuration.

configure vlan default delete ports 1, 11-50
configure ports 49 auto off speed 10000 duplex full
configure ports 50 auto off speed 10000 duplex full
configure vlan Default add ports 1 tagged
configure vlan Default add ports 2-10 untagged
configure vlan Default ipaddress 172.16.10.100 255.255.255.0

cisco-
Switch#show running-config
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption

interface FastEthernet0/1
duplex full
speed 100
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface VLAN1
ip address 172.16.10.200 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
!
line con 0
transport input none
stopbits 1
line vty 5 15
!
end

因為這只是先讓我們練習的機器,所以沒有什麼重要資訊。再麻煩你幫我們看一下謝謝了

bestken iT邦新手 1 級 ‧ 2009-08-20 18:39:06 檢舉

1.你的CISCO沒有設定多VLAN,只有defaultVlan(Vlan1),所以只有一個Vlan,沒有兩個以上!=>設定錯誤!
2.你的Extreme要設定為L3-switch,設定多組VLAN並進行forwarding,才能交換不同
Vlan的封包。
3.如果只是要將cisco-port4-pc1 和 extreme-port4-pc2 能通,不需設定trunk
請參考以下範例試試:
CISCO------------------------->當作一般的L2-switch,沒有多組VLAN
interface FastEthernet0/1 ; 接到extreme
switchport mode access
!
interface FastEthernet0/4 ; 接到pc1
switchport mode access
!
interface VLAN1
ip address 172.16.10.2 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
ip default-gateway 172.16.10.1

bestken iT邦新手 1 級 ‧ 2009-08-20 18:39:13 檢舉

extreme------------------------->
create vlan "v101"
configure vlan v101 tag 101
create vlan "v102"
configure vlan v102 tag 102
configure vlan v101 add ports 1 untagged ;這個port都是vlan101,接到cisco
configure vlan v102 add ports 4 untagged ;這個port都是vlan102,接到pc2
configure vlan v101 ipaddress 172.16.10.1 255.255.255.0
enable ipforwarding vlan v101
configure vlan v102 ipaddress 172.16.20.1 255.255.255.0
enable ipforwarding vlan v102

PC1-ip: 172.16.10.xx/24 getway:172.30.10.1
PC2-ip: 172.16.20.xx/24 getway:172.16.20.1

bestken iT邦新手 1 級 ‧ 2009-08-20 18:42:03 檢舉

兩台互PING應該會通~
就算將cisco撤掉,將PC1接到extreme-port1,也是會通。
最主要是將 extreme 當 L3用 (可以交換封包)
但是CISCO2900只是一般的 L2(不可交換封包),這是不一樣的!

bestken iT邦新手 1 級 ‧ 2009-08-20 19:01:30 檢舉

如果要玩trunk,應該將pc1接到cisco-port4,pc2接到cisco-port5
cisco-port1 to extreme-port1 with trunk
CISCO------------------------->當作一般的L2-switch,設定多組VLAN
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/4
switchport access vlan 101
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 102
switchport mode access
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan101
ip address 172.16.10.2 255.255.255.0 ; cisco manager ip
no ip route-cache
!
ip default-gateway 172.16.10.1
!

bestken iT邦新手 1 級 ‧ 2009-08-20 19:01:39 檢舉

extreme------------------------->當作L3-switch,定義多組VLAN
create vlan "v101"
configure vlan v101 tag 101
create vlan "v102"
configure vlan v102 tag 102
configure vlan v101 add ports 1 tagged ;這個port trunk ,接到cisco
configure vlan v101 ipaddress 172.16.10.1 255.255.255.0
enable ipforwarding vlan v101
configure vlan v102 ipaddress 172.16.20.1 255.255.255.0
enable ipforwarding vlan v102

PC1-ip: 172.16.10.xx/24 getway:172.30.10.1
PC2-ip: 172.16.20.xx/24 getway:172.16.20.1

bestken iT邦新手 1 級 ‧ 2009-08-20 19:02:26 檢舉

試試吧!我是用cisco3550 trunk 到 extreme ,可能指令會有點差!

bestken iT邦新手 1 級 ‧ 2009-08-21 07:42:03 檢舉

更正 PC1-ip: 172.16.10.xx/24 getway:172.16.10.1

問一個很鳥的問題,怎麼證明trunk有起來,是我去PC1 ping PC2有通就是起來了嗎?

bestken iT邦新手 1 級 ‧ 2009-08-25 08:51:10 檢舉

是阿~差不多!

bestken iT邦新手 1 級 ‧ 2009-08-25 08:52:37 檢舉

剛剛發現,我又少COPY一行
configure vlan v101 add ports 1 tagged ;這個port trunk ,接到cisco
configure vlan v102 add ports 1 tagged ;這個port trunk ,接到cisco

請問一下extreme是不是有什麼設定是預設的,需要先刪掉的,因為我對extreme很不熟,cisco的設定是ok了但還是不通,想說是不是extreme有問題。

create vlan "v101"
configure vlan v101 tag 101
create vlan "v102"
configure vlan v102 tag 102
configure ports 49 auto off speed 10000 duplex full
configure ports 50 auto off speed 10000 duplex full
configure vlan Default add ports 1-50 untagged
configure vlan v101 add ports 1 tagged
configure vlan v102 add ports 1 tagged
configure vlan v101 ipaddress 172.16.10.1 255.255.255.0
enable ipforwarding vlan v101
configure vlan v102 ipaddress 172.16.20.1 255.255.255.0
enable ipforwarding vlan v102

interface FastEthernet0/1
switchport mode trunk

interface FastEthernet0/4
switchport access vlan 101

interface FastEthernet0/5
switchport access vlan 102

interface VLAN1
no ip directed-broadcast
no ip route-cache
shutdown

interface VLAN101
ip address 172.16.10.2 255.255.255.0
no ip directed-broadcast
no ip route-cache

ip default-gateway 172.16.10.1

line con 0
transport input none
stopbits 1
line vty 5 15

end

這是我目前的設定上面是extrem下面是cisco,我的接法已經照你的方法接了,port1是extreme和cisco對接,port4接pc1(172.16.10.100/24),port5接pc2(172.16.20.200),pc1和pc2對ping沒回應= =

我沒有接任何router,所以gateway有沒有設沒關係吧

我有多設一個cisco的vlan 102,IP設172.16.20.2/24,這樣會有影響到嗎?

bestken iT邦新手 1 級 ‧ 2009-08-25 14:07:20 檢舉

1.刪除 『configure vlan Default add ports 1-50 untagged
』看看~

2.有關係~因為 extreme 要當L3,所以每個Vlan要有getway

3.我有多設一個cisco的vlan 102=>在哪裡??CONFIG看不到!

沒有啦,是我有多設,對了你方便留msn或既時通嗎?還是email,我想有問題這樣問你比較方便,方便留一下嗎?可以的話kimchen0123@gmail.com寄給我

bestken iT邦新手 1 級 ‧ 2009-08-27 09:04:02 檢舉

基本上~我收MAIL的時間比上IT邦還少!所以....MAIL給了也沒用!
另外如有要貼圖或檔案傳送,你可以放在個人空間後將網址貼給我應該就可以了!

bestken iT邦新手 1 級 ‧ 2009-08-27 10:58:23 檢舉

你試的OK?不行的話,我要找一台2950接來試試看!

不行還是沒辦法建立trunk,指令都不斷檢查都沒辦法,幫忙試試看謝謝你

問一下,為什麼建立trunk不是 cisco port4 接 pc1 然後extreme port4接pc2
然後二個switch的port1對接呢?反而變成cisco port4 接pc1 和extreme port5接pc2

bestken iT邦新手 1 級 ‧ 2009-09-01 09:59:01 檢舉

最近沒時間找機器試~要等等

因為trunk是要將不同VLAN的封包透過有TRUNK的PORT傳送~

所以為了要讓不同VLAN通過TRUNK PORT,(pc1與pc2不同VLAN)
應該將pc1接到cisco-port4,pc2接到cisco-port5 (不是extreme)
cisco-port1 to extreme-port1 with trunk

原來如此,那如果是做成一台switch掛了另一台起來,接法要如何接,跑的trunk也是這樣的用法嗎?

bestken iT邦新手 1 級 ‧ 2009-09-02 16:12:47 檢舉

我不懂你的意思~
反正switch的port 只能跑一個 vlan,除非設 trunk ,才能將多個 vlan 封包轉送到上層的 switch

因該說我要做的是「備援機制」,二台switch互相備援,一台掛了另一台會幫忙服務,這樣的方法行的通嗎?

bestken iT邦新手 1 級 ‧ 2009-09-03 11:54:27 檢舉

互相備援??這跟PC端關係比較大!
(當該switch掛掉,下層的PC必須有另外一條路由連到備援的switch,這個比較困難吧)
請看圖~
http://web-ken.net/share/0001-690x493.png

bestken iT邦新手 1 級 ‧ 2009-09-03 13:11:12 檢舉

我已經測試出來了~請看上面的回答[img][/img/]

我要發表回答

立即登入回答