iT邦幫忙

0

VS2010的目標Framework問題?

我有寫一支程式,專案設定那邊目標FrameWork我是設定2.0,

我在有安裝4.0的XP上測試成功,但是給其他只有安裝2.0的人,卻無法正常運行,

請問這問題該如何解決?安裝轉散發元件太耗時了..

1 個回答

4
lordrd
iT邦新手 2 級 ‧ 2010-11-22 21:41:06
最佳解答

檢查你用的 reference 是否拉到 .net 3.5 或 .net 4.0 的吧 ~

絕對沒有Orz

lordrd iT邦新手 2 級 ‧ 2010-11-23 13:52:11 檢舉

我的意思是指 你用的 reference dll 是否有用到引用 .net 3.5 以上的library的物件 ~
再檢查一下吧

不然就照下列的步驟執行一便看看~

把目標framework 改為 4.0
專案存檔
關掉專案
載入專案
再把目標framework改為 2.0
專案存檔
關掉專案
載入專案
打開 Build 下的 Batch Build
把該專案的所有的舊資料全都 Clean 掉
然後 Rebuild 一次

這些都試過了~

不過我發現再新增一個專案,新增2.0的專案,之後把全部移植過來就ok了Orz

我要發表回答

立即登入回答