iT邦幫忙

0

Cisco Router 語音QoS 設定問題

下圖是示意圖

公司的點主要在A,B為另闢的分點
現有環境為前人建置
我在B點工作
目前遇到的問題如下
AB點間電話以網路方式連接
在流量尖峰時段 A能聽B的聲音清楚 但B聽A的聲音會破碎
我看Router 的QoS設定覺得有問題
請各位幫忙
B點Router下的兩個FE port分別接資料與從交換機來的語音訊號
Serial Port 接至中華電信DSU
--------------設定如下-----------------
policy-map pVoiceLan
class cVoiceLan
set precedence 4

interface FastEthernet0/0
description Data LAN of B
ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
duplex auto
speed auto

interface FastEthernet0/1
description Voice of B
ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
duplex auto
speed auto
service-policy input pVoiceLan
service-policy output pVoiceLan

interface Serial0/0/0
description B to A
ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
encapsulation ppp
service-policy input pVoiceLan
service-policy output pVoiceLan

A點Router下只接一個FE port至L3 Switch
至於怎麼至A點交換機與A點怎麼判定是不是語音資料
則不得而知
Serial Port 接至中華電信DSU
--------------設定如下-----------------
policy-map pVoiceLan
class cVoiceLan
set precedence 4

interface FastEthernet0/0
description Data LAN of A
ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
duplex auto
speed auto
service-policy input pVoiceLan
service-policy output pVoiceLan

interface Serial0/0/0
description A to B office
ip address XXX.XXX.XXX.XXX XXX.XXX.XXX.XXX
ip flow ingress
ip flow egress
encapsulation ppp
service-policy input pVoiceLan
service-policy output pVoiceLan

目前我看設定的感覺是 B點因為有對語音port做QoS所以至A點聲音能清晰
A點因為語音與資料都有同樣的QoS等級 所以導致至B點的語音聲音會破碎

不曉得我這樣的看法對不對 還請各位前輩幫忙

1 個回答

2
playerk
iT邦新手 3 級 ‧ 2012-09-12 09:06:31
最佳解答

您好,
在 A site 的 data, voice 網段是否有分開?如果有的話,請找找看設定檔中是否還有 "class-map match-any cVoiceLan" 的部分?
請在這個 class-map 中,增加 voice 網段的 ACL,如:
match access-group name voice
====ACL====
ip access-list extended voice
permit ip (voice_subnet) (wildcard) any
permit ip any (voice_subnet) (wildcard)

這樣應該可以將 data與 Voice 分開了,這樣是很初步的設定,如果需要詳細的細分,還是請您們的維護廠商,熟悉一下您們的架構後,再依據需求設定,效果可能會比較好。

以上給您參考。

我要發表回答

立即登入回答