iT邦幫忙

0

如何開機不啟動 linux SMB ?

每次開機都會啟動 , 有時忘了關蠻麻煩的
網路上搜尋都是如何啟動 , 沒介紹不啟動
請問要如何不啟動呢 ?

iknowlab 的回答而言,
其實可以說是用 systemd 取代了 initd 成為新版 linux 的趨勢;
自己用到FC12之後,就改裝archlinux。
偶爾用別人的電腦教室,裡面是FC1x的版本,
才發現已是 systemd 為主 + initd 的 compitable,
作為 initd 過渡到 systemd 時,
因應一些程式未考慮到 systemd 而暫時與initd並用並存。

後來的版本主要的軟體應都把啟動檔設到了 /etc/systemd 目錄後,
更新的linux版本,可能就完全以 systemd 取代掉 initd。
(我目前不知道 FC 最新的情況是什麼,
這是就 archlinux 的發展過程,
推測其他linux版本也會如此變動)

所以要問 linux 問題,可能需要把什麼版本說明一下,
有些指令不同linux版本,甚至是不同的版次,指令不見得存在。

FC 把新東西納入的速度遠比 CentOS、redhat 快,
新舊並不見得意味就是好壞,
能解決目前的問題,且不容易有預料及意外的後遺症,
就算是好的作業環境吧。
12
bizpro
iT邦大師 1 級 ‧ 2013-08-28 21:09:24
最佳解答

請以以下指令確認smb是在啟動時執行的:

chkconfig --list |grep smb

設定smb不於開機時啟動

chkconfig smb off

設定smb於開機時啟動

chkconfig smb on

8
pajace2001
iT邦研究生 1 級 ‧ 2013-08-28 17:44:40

如果不想用就移除他阿~這樣就不會啟動了
如果你是 Ubuntu 你可以參考
http://askubuntu.com/questions/74838/how-do-i-completely-remove-samba
這裡有移除SAMBA教學

如果只是單純想關閉可以下指令 /etc/init.d/smb stop
如果不想移除,又想每次開機自動關閉 smb , 你可以把關閉的指令寫在 rc.local 試試看
再不然, 去改一下 smb.conf 讓他無法啟動也是可以

rc.local 這是在那 , 要怎麼找
我的是 centos , 初學者不知怎麼找這個檔

pajace2001 iT邦研究生 1 級 ‧ 2013-08-31 17:33:39 檢舉

在/etc/rc.d/下!!

如果你想學習 Samba 建議你可以看這篇教學
http://linux.vbird.org/linux\_server/0370samba.php

如果你對 linux 還不ˋ是很熟,強烈推薦你看鳥哥的書,
http://www.books.com.tw/exep/prod/booksfile.php?item=0010456315
看完你就變超人了!!飛
我是認真的!疑惑

6
iknowlab
iT邦研究生 4 級 ‧ 2013-08-28 23:05:51

我現在用的是 Fedora Core 19,印象中 FC16 以後就是用 systemctl 來控管系統服務。
啟動服務:systemctl start SERVICE_NAME.service
停止服務:systemctl stop SERVICE_NAME.service
加入開機服務項:systemctl enable SERVICE_NAME.service
移除開機服務項:systemctl disable SERVICE_NAME.service
服務狀態:systemctl status SERVICE_NAME.service
所以,將 samba 移除開機服務項:systemctl disable smb.service

8
hwahuang
iT邦研究生 4 級 ‧ 2013-08-29 07:20:30

是centos的話,就打setup把smb取消掉就可以了。


中文不要亂碼 , 請問是在那改

hwahuang iT邦研究生 4 級 ‧ 2013-08-29 09:39:01 檢舉

windows > translation > use font encoding

0
雷夢掐(lemoncar)
iT邦研究生 5 級 ‧ 2013-09-02 08:57:26

fedora,centos: chkconfig
dedian,ubuntu: sysv-rc-conf
設定開機啟動時該啟動哪些服務。

我要發表回答

立即登入回答