iT邦幫忙

0

Could not create the Java virtual machine of centos

請教大家
這是在centos6.6下使用tomcat7來跑exo平台所產生的訊息 (我是用virtualbox來安裝centos),執行EXO服務會產生下列的訊息
http://ithelp.ithome.com.tw/upload/images/20170614/20003705Cs0NEskHPz.jpg

是因為tomcat的記憶體要特別調整嗎?煩請前輩指點
補充說明:我是參考此篇設定http://www.davidghedini.com/pg/entry/install_tomcat_7_on_centos ,且我有發現https://stackoverflow.com/questions/17291566/import-springsource-into-idea-but-had-a-error-unrecognized-vm-option-maxmetasp ,但我找不到gradle.bat這個檔案,
謝謝

1 個回答

1
bizpro
iT邦大師 1 級 ‧ 2017-06-15 10:39:00
最佳解答

Java 7及以下不支援metaspace, 請安裝最新穩定版的Java 8+.

Java 8+記憶體管理從permgen改為metaspace.
exo使用Java 8+

Java 7, 8, 指的是Hotspot版本. 如Oracle JSE/JDK/JRE, OpenJDK,等, 而Oracle JRockit和IBM JVM原本就是使用metaspace.

ektrontek iT邦研究生 2 級 ‧ 2017-06-15 22:16:21 檢舉

如前輩所說
後來參考此安裝方式,有解決此問題 (https://tecadmin.net/install-java-8-on-centos-rhel-and-fedora/#)
謝謝

我要發表回答

立即登入回答