iT邦幫忙

0

phpemailer Could not connect to SMTP host

<?php
// Import PHPMailer classes into the global namespace
// These must be at the top of your script, not inside a function
require './PHPMailer/src/Exception.php';
require './PHPMailer/src/PHPMailer.php';
require './PHPMailer/src/SMTP.php';

use PHPMailer\PHPMailer\PHPMailer;
use PHPMailer\PHPMailer\Exception;

//Load Composer's autoloader
// require 'vendor/autoload.php';

$mail = new PHPMailer(true);                              // Passing `true` enables exceptions
try {
    //Server settings
    $mail->SMTPDebug = 4;                                 // Enable verbose debug output
    $mail->isSMTP();                                      // Set mailer to use SMTP
    $mail->Host = 'smtp.gmail.com';  // Specify main and backup SMTP servers
    $mail->SMTPAuth = true;                               // Enable SMTP authentication
    $mail->Username = 'xxxx@gmail.com';                 // SMTP username
    $mail->Password = 'xxx';                           // SMTP password
    $mail->SMTPSecure = 'tls';                            // Enable TLS encryption, `ssl` also accepted
    $mail->Port = 587;                                    // TCP port to connect to

    //Recipients
    $mail->setFrom('xxxx@gmail.com', 'Mailer');
    $mail->addAddress('xxxx@gmail.com', 'Joe User');     // Add a recipient




    //Content
    $mail->isHTML(true);                                  // Set email format to HTML
    $mail->Subject = 'Test';
    $mail->Body    = 'This is the HTML message body <b>in bold!</b>';
    $mail->AltBody = 'This is the body in plain text for non-HTML mail clients';

    $mail->send();
    echo 'Message has been sent';
} catch (Exception $e) {
    echo 'Message could not be sent. Mailer Error: ', $mail->ErrorInfo;
}

我把google帳號的案全性降低了,然後也去php.ini理把opensll.dll前的分號給刪了,也去爬了一些文,但都沒有效

louischou iT邦新手 4 級 ‧ 2018-03-26 09:19:21 檢舉
google SMTP port 是 465,建議再另外搜尋一下phpmailer的各項設定
fumk iT邦新手 4 級 ‧ 2018-03-27 09:08:12 檢舉
如果轉用465. port應該要轉用SSL.

尚未有邦友回答

立即登入回答