iT邦幫忙

0

關於red_hat updat 發生錯誤的問題

目前我的作業系統是redhat7.0然後來源第三方是cetnos7.6版本
進行update會出現錯誤
如下
Error: unbound-libs conflicts with redhat-release-server-7.0-1.el7.x86_64
Error: initscripts conflicts with redhat-release-server-7.0-1.el7.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
然後使ㄩ然後使用skip-broken去跑反而會當機
請問該如何呢
是應該直接重新裝一個新版的os
還是update上去呢可是update一直上不去
目前卡在這裡想要安裝docker還有zabbi的監控軟體都會出現這樣的問題
請問還如何處理呢

剛剛查了一下
好像用 rpm -e redhat-release-server-7.0-1.el7.x86_64 --nodeps
就可以把問題解決了
那想請問有沒有其他辦法呢
因為不可能每個都可以移除

1 個回答

0
vegalou
iT邦新手 4 級 ‧ 2019-06-16 07:39:30
最佳解答

RH本來就跟CentOS不同支,

既然都用docker幹嘛還昇OS?

zabbix直接tarball編一下就好了,還大費周章走一大圈。

除非你對Linux不熟。

zebrakky iT邦新手 5 級 ‧ 2019-06-16 08:48:45 檢舉

不好意思因為我在安裝ZABBIX 也出現這個問題
而且我DOCKER安裝的時候也出現這個問題
所以我DOCKER沒有安裝
後來才想說是不是UPDATE沒更新的問題
至於LINUX我的確不熟悉
所以想請問大大我該如何處理呢
昨天更新玩後直接變CENTOS7.6版
反而又發生其他問題了

我要發表回答

立即登入回答