iT邦幫忙

0

mongodb的c驅動使用

我打算寫code讓c語言能連到mongo,所以我安裝mongo c driver:
http://mongocxx.org/
第一步要先安裝:mongocxx
http://mongocxx.org/mongocxx-v3/installation/
但在步驟4 cmake 過不了

中文版(https://www.twblogs.net/a/5d4417e7bd9eee5327fb425f)

以下有幾個問題想問各位大神:
1.我想寫在c code而非C++ 是可以的嗎?如果可以那還需要裝這個嗎?
(p.s.若不行會使用c++)
2.步驟2中"Choose a C++17 polyfill"是如何操作?
3.執行步驟4中"cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr/local .."噴了以下ERROR如圖,該如何解決
https://ithelp.ithome.com.tw/upload/images/20191016/20111112FJQdkd5BNI.png

我的環境:
gcc version 5.4.0 20160609
ubuntu 16.04
mongo-c-driver 1.15.1(https://github.com/mongodb/mongo-c-driver/releases)
libbson、libmongoc 按照下面網址
(http://mongoc.org/libmongoc/current/installing.html)
想要mongocxx 3.4.x

尚未有邦友回答

立即登入回答