iT邦幫忙

0

SQL Server 使用Oracle Client 19c執行排程出現: 提供者 "oraoledb.oracle" 提供了不一致的中繼資料。執行時提供了編譯時間所沒有的額外資料行。

原廠回覆要從這裡
下載<Patch 32832237>更新,就不會有這個問題囉~


不好意思打擾各位了><
我在SQL Server 2016上設定連Oracle的連結伺服器測試連線成功(使用Oracle Client 19c)
查資料甚麼的都查的到 基本上連線是沒有問題的
但是我在執行排程的時候 有時候會出現以下錯誤訊息:
提供者 "oraoledb.oracle" 提供了不一致的中繼資料。執行時提供了編譯時間所沒有的額外資料行。
但是! 用Oracle Client 11g就完全不會有任何問題
請問有大神知道為甚麼會這樣嗎?
謝謝各位!!

1 個回答

1
一級屠豬士
iT邦大師 1 級 ‧ 2021-08-31 11:41:05
最佳解答

Oracle19c 的排程內部使用的table,就是meta data (中繼資料)
,有新增的欄位,就翻譯成 (額外資料行), 是你的db link 建立時( 編譯時間 ),是照之前版本的,
他不能完全理解,所以就提出警告了.

看更多先前的回應...收起先前的回應...
lulu_meat iT邦新手 4 級 ‧ 2021-08-31 13:56:53 檢舉

謝謝您的回答! 不好意思我不太懂您的意思 請問這個問題要怎麼解決呢?

lulu_meat iT邦新手 4 級 ‧ 2021-08-31 13:59:49 檢舉

請問這個問題的解決辦法只能重新安裝oracle client 11g嗎?
因為只有在11g的版本不會有這個問題

lulu_meat iT邦新手 4 級 ‧ 2021-08-31 14:19:21 檢舉

我有查到這個網站有提到一樣的錯誤訊息

你用SQL Server DB Link 連去 Oracle 19c 操作,
既然都告訴你,他無法完全支持了.還能怎樣解決,看SQL Server 的廠商有沒有出新的版本來配合啊.
可以用Oracle 出的 https://www.oracle.com/tools/downloads/sqldev-downloads.html
來操作.
用SQL Server DB Link 連, 多增加了一層,連帶多了相容性的問題.
他都很明確的告訴你,臣妾做不到,要麻等升級,要麻換另外方法,不要糾結在那裡.

lulu_meat iT邦新手 4 級 ‧ 2021-08-31 17:42:45 檢舉

謝謝您的回覆>< 我了解您的意思了~

我要發表回答

立即登入回答