iT邦幫忙

2

你升級firefox 6.0了嗎?

firefox 6.0正式推出了,很多媒體在報導新版的特色,但download有會員提出升級時遭遇附加元件不相容的問題...
小當家也有遇到相同的狀況
許多附加元件在firefox升級到6.0,會發生不相容的情況
有一些是我常用的plugin
所以我就放棄升級了

不知道iT邦的各位大大如何解決呢?
大家可以到iThome download發表看法唷!
本想更新Firefox到6.0版,但發生附加元件不相容的問題,你決定升級嗎?

記得要常來玩唷!


2 則留言

0
總裁
iT邦好手 1 級 ‧ 2011-08-19 15:26:06

我剛剛才發現我用的就是6.0....失神

download iT邦新手 4 級 ‧ 2011-08-19 15:52:12 檢舉

那你沒有遇到附加元件不相容的情況嗎?

都不到download留言,人家好傷心..(哭哭)

總裁 iT邦好手 1 級 ‧ 2011-08-19 16:22:59 檢舉

可能我都沒用那些元件吧,如果您沒提,我都沒注意到我的FF已經升到6.0了...

0
wiseguy
iT邦超人 1 級 ‧ 2011-08-19 21:52:28

大部份的附加元件應該都是可以在新版使用的
只是作者還懶得去檢查,並且更換新版
所以可以自己依下列方式來<升級>

  1. 下載附加元件的 .xpi 檔案,儲存到硬碟上
  2. 更改附檔名為 .zip
  3. 解開所有檔案到一個目錄中
  4. 用個純文字編輯器 (Ultraedit、emeditor、editplus ...) 開啟 install.rdf
  5. 找到 <em:maxVersion>???</em:maxVersion> 這個地方。??? 也許只到 5.0.* 而已,把它改為 6.0.*,並存檔。
  6. 重新把所有檔案壓縮成 .zip 檔,並更改附檔名為 .xpi。注意不要把解壓目錄給包進去,install.rdf 一定要在壓縮檔根目錄下才對。
  7. 雙擊這個 .xpi 用 firefox 去開啟,就可以安裝了。

我要留言

立即登入留言