iT邦幫忙

4

jQuery 1.9注意事項

1.jQuery 1.9.0 於 2013年1月15日發佈, 1.9.0拿掉一堆過時的API
http://jquery.com/

2.升級到jQuery時, 需留意...
http://jquery.com/upgrade-guide/1.9/
有人翻成中文的簡介
http://blog.darkthread.net/post-2013-01-28-jquery-1-9-migrate.aspx

3.如果有使用jQuery UI的話, 請記得也更新 jQuery UI 到 1.10.0版
http://jqueryui.com/download/
之前jQuery放在 Google Code的SVN只到1.8.24版, 1.9以後的版本, 似乎沒開放SVN下載?
http://jquery-ui.googlecode.com/svn/tags/
(個人以前的經驗, 更新jQuery, 卻忘了更新jQuery UI, 結果網頁跑起來問題一堆)

4.其它jQuery相關Plugin對於jQuery 1.9.0的相容性, 待查...


0
ted99tw
iT邦高手 1 級 ‧ 2013-01-29 19:54:03

讚啦,䓤油餅遞出...

0
炎之虛空
iT邦高手 3 級 ‧ 2013-01-30 08:47:15

目前遇到有一套Autocomplete plugin
這個就是自動輸入的套件
1.9.0之後完全無法動作XDDDDD
解決方式

<pre class="c" name="code">
$.browser.opera

改成

<pre class="c" name="code">$.browser

就可以正常了

appleboy iT邦新手 4 級 ‧ 2013-01-30 09:43:16 檢舉

可以參考我之前寫的文章

http://blog.wu-boy.com/2013/01/jquery-1-9-final-jquery-2-0-beta-migrate-final-released/

以及一篇升級指南

http://blog.darkthread.net/post-2013-01-28-jquery-1-9-migrate.aspx

另外 jQuery.browser() 已經過時,並且在 1.9 移除,所以請不要在使用了

我也很不想支援舊版本的瀏覽器
不過你也知道的麻
使用者就是很喜歡念舊
我還遇過
主機都很頂的客戶(32GDDR3+I7+256G SSD)
系統只裝XP..............
只為了說.......因為我不習慣WIN7汗

0

player提到:
1.jQuery 1.9.0 於 『2003』年1月15日發佈, 1.9.0拿掉一堆過時的API
http://jquery.com/

2003年@@

0
player
iT邦大師 1 級 ‧ 2013-03-28 18:19:22

錯字
都到 1.9.1 了, Orz

日前發現
jQuery Alert Dialogs Plugin
http://www.codeproject.com/Articles/114889/jQuery-Alert-Dialogs-Plug-in

這個Plugin掛了, 原因不明, Alert Dialogs 不知道開在那裡? 導致網頁的操作卡死?

我要留言

立即登入留言