iT邦幫忙

0

我的電腦區域網路,或是遠點連線都不行,問了半年都找不到答案

設備狀態:A.B兩台電腦,作業系統XP SP3,防毒裝avast home,遠端裝pcanywhere,其中A台裝iis,SQLserver,B台用區網連A台的iis網頁作業
發生狀況:本來都很正常,有一天B台突然無法連線到A台的網頁,ping也ping不到,從遠端也ping不到A台,但A台上網正常,也可以ping到別台電腦,但所有方法都無法連線到A台,有試過防火牆關掉,移除防毒,移除iis SQL,但都無法連線或ping到A台電腦,但如果用XP內建的還原系統程式還原到前幾天,就可以連線到A台了,但只能維持幾天又會發生同樣的狀況,又要從新在還原一次,但同樣的電腦規格跟作業系統,B台就從來不會發生,就只有A台,這個問題困擾我很久,不知道有沒有人可以幫我找到答案,小弟會感激不盡..

tom6507 iT邦大師 1 級 ‧ 2009-05-27 23:55:14 檢舉
把A電腦中的"服務"中的所有內容抓圖下來看看吧
envboss iT邦新手 5 級 ‧ 2009-05-30 17:42:09 檢舉
因為無法連線進去,所以暫時沒辦法抓,過幾天過去現場,我在抓下來給你看看,感謝
38
sphinx
iT邦研究生 3 級 ‧ 2009-05-28 06:37:43
最佳解答

從你的描述看起來,問題似乎是出現在A台,建議分別試試下列三個方法:
1.系統還原之後暫時關閉WINDOWS自動更新,觀察是否過了幾天仍會斷線。
2.上網看看主機板晶片組、網路卡是否有新版的驅動程式,若有則更新之。
3.換一片網路卡。
如果以上三個辦法都不行,那就只好祭出尚方寶劍--另外拿個硬碟重灌Windows,盡量只安裝最優先需要的軟體,比如 iis、sql server,運作幾天觀察是否會發生問題,再慢慢加上其他軟體,有時候與其浪費許多時間抓問題,還不如重灌來得快些。

看更多先前的回應...收起先前的回應...
jamesjan iT邦高手 1 級 ‧ 2009-05-28 12:39:37 檢舉

我也是這麼覺得,重灌順便將設定完的環境做成 image 檔
有時間再好好抓一下問題

envboss iT邦新手 5 級 ‧ 2009-05-30 17:36:28 檢舉

我之前也從灌過,剛開始可以,但過了沒多就又會發生同樣的狀況,我之前也有懷疑過是網卡的問題,所以我把AB兩台的主機對調,讓原本的A台變B台,原本的B台變A台,但原本沒問題的B台主機灌成A台後,又會發生同樣的問題,所以我還是懷疑是軟體問題

sphinx iT邦研究生 3 級 ‧ 2009-05-30 21:28:16 檢舉

建議更換網卡並非認為是網卡故障,而是覺得可能是驅動程式的問題,也許換個不同的網卡會解決您的問題。

sphinx iT邦研究生 3 級 ‧ 2009-05-31 07:50:49 檢舉

另外,也可思考是否有中毒、遭入侵或是Web AP被裝置後門程式的可能性。

envboss iT邦新手 5 級 ‧ 2009-06-02 00:42:08 檢舉

1.可是如果是驅動程式問題,但2台機型跟軟體都驅動都一樣,但B台電腦都不會有這種狀況,只有A台會,而且還原後就正常了,可以維持幾天.
2.我有掃毒過,是沒什麼問題,沒有用AP等裝置.

sphinx iT邦研究生 3 級 ‧ 2009-06-02 06:30:12 檢舉

1.有可能是微軟的某個更新程式和電腦的驅動程式衝突,所以建議您復原之後暫停自動更新,或是更新驅動程式看看。也因為您一直用相同規格的電腦在測試,所以會抓不到問題,說不定換張不一樣的網路卡就OK了。
2.Web AP指的是網頁的程式,如果您的網頁有開放internet可以連線,也可能會因為存有安全漏洞而被人破壞。

32
bizpro
iT邦大師 1 級 ‧ 2009-05-27 16:42:51

有時候防毒軟體會和遠端遙控軟體相衝, 不見得是那一牌一定會這樣, 可能在某一版本會有衝突. 您有換過防毒軟體過嗎? 用不同的遠端遙控軟體?

看更多先前的回應...收起先前的回應...
envboss iT邦新手 5 級 ‧ 2009-05-30 17:25:49 檢舉

防毒跟遠端都移除過,還是無法連線,一定要還原才可以連線

bizpro iT邦大師 1 級 ‧ 2009-05-30 23:01:53 檢舉

您是使用DHCP嗎? XP sp3 在某些特異的情況下會有問題, 微軟有hotfix, 但是並不能直接下載更新, 必須聯繫微軟的.

tom6507 iT邦大師 1 級 ‧ 2009-05-31 12:24:22 檢舉

hotfix的連結提供一下吧

envboss iT邦新手 5 級 ‧ 2009-06-02 00:37:58 檢舉

1.沒有使用DHCP,2台電腦直接接到中華電信的數據機,兩台有設定固定IP192.168.0.3~4,然後用windows內建的pppoe撥接上網
2.hotfix是做什麼的,可以修補這個問題嗎?可以提供安裝的位置或方法嗎?感謝!!

bizpro iT邦大師 1 級 ‧ 2009-06-02 22:32:25 檢舉

既然您不是使用DHCP, 那個hotfix是無意義的. 關於那個Hotfix, 必須詢問微軟的, 我並沒有.
我在網上讀了一些關於SP3和pppoe網路斷線的問題, 文章參考: http://social.technet.microsoft.com/forums/en-US/itproxpsp/thread/2cdfb22e-7e52-4581-8c62-32439159ce04/
這篇文章可能與您的問題不是很接近, 但是提供了一些思路, 有可能是有一些Hotfix(es)和router有關的, 也有可能是中華電信內建的router本身的問題, 您是否試過不要直接連中華電信的數據機呢?

envboss iT邦新手 5 級 ‧ 2009-06-04 11:37:41 檢舉

1.PPPOE並沒有斷線
2.如果是中華電信內部的router有問題,但為什麼我電腦本身系統還原就OK了.

bizpro iT邦大師 1 級 ‧ 2009-06-07 17:08:05 檢舉

1.PPPoE有沒有斷線與此問題無關, 是B台電腦斷線.
2.也許是XP的某個更新會造成加上router的其他因素的交互影響. 還原後就OK了.
我只是提供可能的方向, 我的建議是先將目前問題發生的現象紀錄, 紀錄多少時間後B台會發生問題, 發生問題的機率, 作為對照組, 然後將造成問題的可能因素排除到最少狀況, 再逐一和對照組比對, 排除假因素, 反復測試吧. 例如:
a.停止XP更新, 看看是否不再發生問題.
b.不直接連中華電信ATUR.
c.a和b一起排除.
d....

30
蟹老闆
iT邦大師 1 級 ‧ 2009-05-27 17:33:52

傑克這真是太神奇了,
這個狀況看來也只能一個一個試了,

有試過A ping B嗎通嗎?
IP 是否固定?
IP 是否在同一網段?
有IP 分享器嗎?
DHCP 有開嗎?

我也分享一個神奇的傑克吧,數年前有一天客戶說他電腦開不了機主機帶來給我看,結果我什麼也沒做只按了POWER鈕,大概看了一下沒什麼問題就讓客戶帶回去,回去後還是說不能開機我就請他有空將螢幕帶來看,結果也是沒問題,但回去後就是開不了,連正常開機的嗶聲也沒有。
沒辨法只好請我過去看,過去後果然如客戶所言開不了機...查了查將螢幕的接頭拆下不與主機連接,居然可以開了,接回又開不了,最後只好將它們二個分開,原因可能是它們二個搭配久了想換換新鮮的。到現在那螢幕跟pc都分別在運作中,
到目前我共遇過二台這種情況,只能說傑克你太神奇了

看更多先前的回應...收起先前的回應...
envboss iT邦新手 5 級 ‧ 2009-05-30 17:27:45 檢舉

B ping A-->正常
A ping B-->ping不到
都同一個網段...因為A我設192.168.0.3 B設定192.168.0.4
沒用ip分享器.

envboss iT邦新手 5 級 ‧ 2009-05-30 17:29:45 檢舉

說錯抱歉><
B PING A-->PING不到
A PING B-->正常

蟹老闆 iT邦大師 1 級 ‧ 2009-05-30 20:11:57 檢舉

依你描述看起來確實像是軟體問題。
還原後到出問題的這段期間有無要你確認什麼的訊息嗎?如果有是哪方面的訊息
也可以查看日誌檔看看出問題之前有沒有什麼記錄可查

envboss iT邦新手 5 級 ‧ 2009-06-02 00:39:31 檢舉

還原後到出問題都沒出現什麼異狀,就是禿然連不近A台電腦,也沒什麼訊息或錯誤,還有日誌檔裡有很多東西,我也看不太懂

蟹老闆 iT邦大師 1 級 ‧ 2009-06-09 04:41:40 檢舉

這個問題確實很怪,要找出問題我想在這可能暫時會找不到,如果不想在每次還原或許二個做法:
一、請另一個專業人士看看或許別人會有不同的思路
二、系統重新安裝

蟹老闆 iT邦大師 1 級 ‧ 2009-06-09 04:43:02 檢舉

是重新安裝系統,不是應用程式

32
kaiin323
iT邦高手 1 級 ‧ 2009-05-27 17:49:32

你先在A跟B上裝siffer軟體(如Ethereal)
觀察一下到封包的傳送是有什麼問題:

1.根本沒收到封包(對方或線路有問題)
2.收到封包但沒送出去(自己有問題)
3.收到封包了也送出去了但對方沒收到(對方or線路有問題)

以釐清到底出問題的是哪個節點,
然後再來討論有可能的原因會比較實際一點

envboss iT邦新手 5 級 ‧ 2009-05-30 17:40:34 檢舉

siffer我沒用過,我會去試看看,但兩台電腦是直接接到中華電信的數據機,所以線路因該沒什麼問題,還有就是A台任何電腦都PING不進去也連不進去,siffer軟體有辦法測試哪裡有問題嗎?

kaiin323 iT邦高手 1 級 ‧ 2009-06-08 09:40:04 檢舉

sniffer可讓你看到是否有收到ping的封包,且卻確認是否有送出,就跟我回答所講得基本要領三點一樣,你兩邊都要裝,藉以觀察到底是哪個節點出了問題

24
Ken(Bigcandy)
iT邦大師 1 級 ‧ 2009-05-30 16:13:44

1.最簡單的,先換一片網路卡
2.其次,弄一個乾淨的os
3.抓封包找問題

envboss iT邦新手 5 級 ‧ 2009-05-30 17:37:44 檢舉

我主機整台換過了,還是一樣,OS我是用原版XP光碟+原版序號去灌,還是一樣

如果硬體『可能』沒問題
就依照回答:kaiin323( IT邦好手1級 )
抓封包試試看吧
說不定封包根本沒離開過你這部電腦

envboss iT邦新手 5 級 ‧ 2009-06-02 00:43:26 檢舉

正常的時候,B台電腦每天都會連A台電腦抓資料,所以封包因該是有離開過.

24
nineone
iT邦新手 2 級 ‧ 2009-05-31 23:24:24

1.先去系統內容查看工作群組是否有一樣
2.你目前電腦是否有二台 還是二台以上 可能是IP192.168.0.3 IP可能重複
3.查一下 你網路區段是否有一樣 192.168.0.3 / 255.255.255.0 /192.168.0.1(假設位置)
4.另外一種機率不大 網路線接頭重打 可能收沒有問題 發會掉封包
5.再一種更不可能 是網路卡 重新安裝驅動看看 (之前做網路工程師有發生過 最後用另外網路卡就OK了 很難解釋)

envboss iT邦新手 5 級 ‧ 2009-06-02 00:34:58 檢舉

1.工作群組一樣..workgroup
2.只有2台電腦,沒有別台
3.網路頭沒問題,因為系統還原就正常了
4.驅動從新安裝過,系統也從灌過

18
ok538
iT邦新手 5 級 ‧ 2009-06-03 14:13:19

您的問題,我認為應該是中毒或是駭客程式,幾年前我也遇過類似的問題,客戶的主機原本都正常,但突然所有工作站的連不到主機,可是主機上網或連線都正常,最後發現主機啟動時載入了一個怪怪的程式,想辦法將他移除後就一切正常
就您的狀況我給您幾個建議
第一請花點小錢買台IP分享器,因為microsoft的軟體漏洞那麼多,您還敢讓他直接曝露在internet上,不被駭是蠻難的,
第二不知您的administrator帳號有無設定密碼,若沒有請盡快設定,因PC直接上網,又沒設定密碼,根本是跟駭客說"歡迎來坐",XD
第三若您的技術可以,請查查看regedit看看是否開機時有無載入奇怪的程式,或是利用msconfig將啟動時載入的程式都關掉,若您真的找不出來,比較簡單的方式一樣是還原,只要您有做上面兩步驟(還原完記得要再設定密碼),我想這狀況應該就不會再出現
最後,若您上面三個步驟都做了,問題還是一樣,那很有可能是您的另一台電腦中毒了,

小小建議,提供參考,希望可以解決您的問題

envboss iT邦新手 5 級 ‧ 2009-06-04 11:40:36 檢舉

1.有用過ip分享器,但情況還是依樣
2.administrator有設定密碼
3.就算另一台沒開機,其他電腦也無法連到A台

ok538 iT邦新手 5 級 ‧ 2009-06-09 14:58:30 檢舉

就您的回答...我覺得您還是沒有看懂我的說明...
基本上照我的建議是...第一二項是一定要做.....
而我的第三個建議只是提供你解決方案...
而且您 3.就算另一台沒開機,其他電腦也無法連到A台 =>完全跟我說明的狀況不一樣
我再重新說明一下
#一:請您裝上IP分享器,二:確定administrator有設定密碼(最好兩台pc都設不一樣),三:將A台電腦還原或重灌,四:建議將B台電腦也重灌!
這樣做完您說的狀況應該就不大會再發生了

18
dick
iT邦新手 5 級 ‧ 2009-06-07 16:23:28

如果超過半年了,還沒有解決的話,真的很令人垂頭喪氣,但有一辦法可以百分之百解決你的問題!需要有一個略懂電腦網路的同學或哥哥或弟弟……

叫你的哥哥、弟弟或同學坐在 A台電腦旁 ,你則坐在 B台電腦旁,當你需要遠端遙控 A台電腦時,打電話過去,遙控你的兄弟或同學去操作電腦……!

這樣就完成了人肉遠端遙控的功能!

我要發表回答

立即登入回答