iT邦幫忙

0

WSUS error-KB953297, KB971108

ccdm 2009-12-10 10:23:188931 瀏覽

請教站上新進,在安裝KB953297, KB971108時出現找不到產品安裝來源,畫面出現插入.net framework 1.1安裝磁片,
已檢查pc已安裝過.net framework 1.1 & 2.0,在c:\windows下沒看到相關對應之log檔,不知道什麼原因造成更新失敗,謝謝。

2 個回答

10
tom6507
iT邦大師 1 級 ‧ 2009-12-10 10:44:31
最佳解答

重新安裝.net framework 1.1看看
.net framework 1.1官方下載

ccdm iT邦新手 5 級 ‧ 2009-12-10 11:09:37 檢舉

您好,已試著重新安裝.net framework 1.1,無法安裝,故檢查os發現內已安裝.net framework 1.1和.net framework 2.0,pc os版本是windows 2000

tom6507 iT邦大師 1 級 ‧ 2009-12-10 11:22:24 檢舉

移除後再重裝呢

6
infornet
iT邦高手 1 級 ‧ 2009-12-11 17:54:46

步驟一:安裝Windows Install Clean
步驟二:執行windows Install clean 找到net 1.1 or 2.0 選remove移除。(看您是1.1
還是2.0有問題就移那一個。)
步驟三:刪除[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework
Setup\NDP\???? 看您是那一個版本無法解除安裝的。
語法如下:
x86執行此命令: reg delete "HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v2.0.50727" /v Version /f
x64執行此命令:reg delete "HKLM\SOFTWARE\Wow6432Node\Microsoft\NET Framework Setup\NDP\v2.0.50727" /v Version /f

步驟四:重新安裝Net Framework 1.1 sp?
步驟五:重新KB953297, KB971108

ps.請先確定您的net 1.1 及 2.0 是否都有相同的情況,若是,建議二個都照上述步驟移除後重新安裝。

ccdm iT邦新手 5 級 ‧ 2009-12-16 12:42:54 檢舉

您好,已按照您提供教學,將.net framework 1.1解決,但2.0遇到問題,
處理步驟為:
(1)執行windows Install clean找到.net 2.0選remove移除
(2)刪除[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework
Setup\NDP\????
(3)reg delete "HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v2.1.21022" /v Version /f
(4)安裝 .net framework 2.0

錯誤訊息為:the version of the .net framework is incompatible with a previously installed one (http://support.microsoft.com/KB/906894)

kuo1142 iT邦新手 5 級 ‧ 2010-02-11 11:57:31 檢舉

我安裝了Windows Install Clean 可是到處都找不到 到底安裝在哪
我NET Framework除1.1還有2.0和3.0;2.0 3.0 都是SP2版的
系統本身是SP3 所有最新的更新都能裝 只差微軟的KB953297更新

我要發表回答

立即登入回答