iT邦幫忙

0

ESXi5+FreeNas8 iSCSI 問題

請教各位前輩,這幾天小弟在公司架設LAB環境
在ESXi5上架設兩台虛擬ESXi5+一台FreeNas8(RELEASW-p2-x64版本)
期望兩台虛擬ESXi能用iSCSI方式連接FreeNas Storage 達成HA環境。
設定完成後,發現ESXi iSCSI Adapter 無法順利看到FreeNas分享的LUN
錯誤訊息: The iSCSI initiator could not establish a network connection to the target
主機全都同網段,能互通,沒有特殊設定
所有設定移到單一NB Workstation上模擬,卻不會出現這樣的問題 ?
不知道有沒有前輩能給些建議,處理這個問題,感謝。
若有資訊提供不足,還請提出,我會再補充,感激不盡。

2
xexxo2002
iT邦新手 4 級 ‧ 2012-05-18 11:48:15
最佳解答

我目前有 ESXi5+FreeBSD Storage 的 production 環境,是否可以請你貼 vclient 的網路設定圖參考看看?
這是我環境的設定,參考看看

看更多先前的回應...收起先前的回應...
funkband iT邦新手 5 級 ‧ 2012-05-18 13:49:46 檢舉


我也是分VM網路和Storage網路,無論放在同網段或是切獨立網段給Storage結果是一樣的!!

hector958 iT邦研究生 2 級 ‧ 2012-05-18 17:32:29 檢舉

既然是要建HA,想必也有建一台VC吧,VC的iSCSI能連到FREENAS嗎?
或是隨便建一個WINDOWS VM,iSCSI測試看看。
確認一下是FREENAS問題還是ESXi問題。

xexxo2002 iT邦新手 4 級 ‧ 2012-05-18 23:56:35 檢舉

有兩個可能的問題點:

  1. vmk1 這張虛擬網卡有 bind iscsi 成功嗎?
  2. 網路架構上,esxi ping 得到 freenas,但是是從 .190 這一段出去的,.192 完全無作用,這個部份要看 esxi 的 routing table,再來就要看是不是有設到 vlan id,導致 vmk1 無法存取;總之,把 vmk1、freenas 移到跟 management port 不同的網段試試,如果 ok 的話就是 routing table 作怪了。
    這兩點都沒問題的話,剩下的問題點大概是在 freenas 上了。
funkband iT邦新手 5 級 ‧ 2012-05-21 11:16:48 檢舉

感謝大家的幫忙。 我簡化環境如下:
ESX Manager IP 為 192.168.101.190
VMKernel IP 192.168.101.200
FreeNas IP 192.168.101.194
在ESX上使用Ping & vmkping 兩個指令透過Manager和VMKernel ip 進行網路確認。

用同網段另一台WIN7 iSCSI 啟動器連線FreeNas 進行Nas確認,可成功掛載硬碟。

在ESX Dynamic Discovery 上加入 FreeNas IP !
Rescan後static Discovery 自動出現 FrreeNas IQN

但是無法看到FreeNas上的硬碟,且出現錯誤訊息。

ESX防火牆我檢查過,3260有開啟,
想請教大家是不是有那裏弄錯或是我還可以做什麼測試來找問題嗎??

2
jerry710822
iT邦高手 1 級 ‧ 2012-05-17 20:17:36

先檢查一下ESXI是否可以PING到FREENAS

funkband iT邦新手 5 級 ‧ 2012-05-17 22:28:38 檢舉

funkband提到:
有.. ESXi 可以ping到FreeNas

2
chang0206
iT邦新手 1 級 ‧ 2012-05-18 10:38:52

iscsi 的讀取權限有設定好嗎?

funkband iT邦新手 5 級 ‧ 2012-05-18 13:51:43 檢舉

讀取權限,是WR設定嗎!?
我認為應該是沒問題,因為我在Workstation上設定時候是沒問題。
但是在ESX上模擬的時候就會出現問題。

2
raytracy
iT邦大神 1 級 ‧ 2012-05-21 17:38:15

您的 FreeNAS 版本是多少?

這個是 8.0.1-RC2 以前的舊問題, 應該在升級到 8.0.2 以後就已經解決了才對.
r7419 - Updated to vsphere 5 & now iSCSI doesn't find any disks

funkband iT邦新手 5 級 ‧ 2012-05-21 17:52:34 檢舉

我目前的版本是:FreeBSD 8.2-RELEASE P7
請問這個版本也會有問題嗎 !!?? 感謝

funkband iT邦新手 5 級 ‧ 2012-05-24 12:06:32 檢舉

感謝各位前輩幫忙,小弟找到解決方法了 !!!
原本設定FreeNas的vSwitch並沒有Bind任何Uplink !!
因為原本想說是內部互通即可,卻沒辦法看到Storage LUN !!
最後將設定移到有Bind Uplink 的vSwitch上就可以了!!
雖然原因還不是很清楚,但是只少先可以先用,感謝大家 !!

我要發表回答

立即登入回答