iT邦幫忙

0

電腦換了新設備虛擬電腦玩遊戲還是很LAG

qpxn 2012-06-10 13:14:1013518 瀏覽

我試用了Virtual pc跟VMWARE Workstation 8
虛擬系統是windows xp sp3
玩的遊戲是私服的石器時代 2D遊戲
遊戲在虛擬系統內進行雙開就很LAG
在Virtual pc上雙開~效能顯示cpu總是100%
在vm上設4核跟2g ram~也是一樣LAG
但有玩家電腦設備才雙核cpu(Q8200)跟2g ram 用xp系統加virtual pc 2007~就沒有這個lag的問題~
但我要使用usb無線網絡的關係,一定要使用win 7或vmware



請大大們幫忙一下!

小成 iT邦高手 10 級 ‧ 2012-06-11 13:55:50 檢舉
CPU是XEON耶@@
8
cmwang
iT邦高手 1 級 ‧ 2012-06-10 13:38:01
qpxn iT邦新手 5 級 ‧ 2012-06-10 14:55:46 檢舉

不明白~

cmwang iT邦高手 1 級 ‧ 2012-06-10 16:47:43 檢舉

另一個thread:關於AMD-V 虛擬化的小問題,這是VM先天上就不適合拿來跑I/O bound AP所致,硬要這麼幹不是不行,只是C/P值划不划算而已Orz....BTW,在VM中跑吃VGA的AP(i.e. game之類)lag不lag本來就因人而異了(同樣的狀況,有人覺得很lag,但可能也有人覺得還可以接受),您只說有人覺得不會lag,卻沒搞清楚他說的不會lag到底是多lag,soOrzOrz....

qpxn iT邦新手 5 級 ‧ 2012-06-10 22:18:51 檢舉

要知他LAG不LAG很簡單~加入他的隊跟他一起掛網~就是感覺很順~

10
liurambo0911
iT邦高手 1 級 ‧ 2012-06-10 21:54:44

試試看用VirtualBox吧
至少可以支援D3D 應該可以順一些 (吧?

qpxn iT邦新手 5 級 ‧ 2012-06-10 22:19:50 檢舉

VirtualBox我有試~但不能用USB無線網絡~~無次跟我都說代碼10~

qpxn提到:
代碼10

貼個畫面來看看
是遊戲的錯誤訊息 還是VM的錯誤訊息

還有 怎麼不試試看直接選成NAT模式 這樣就根本不用去選USB無線網卡了

cmwang iT邦高手 1 級 ‧ 2012-06-13 09:08:33 檢舉

liurambo0911提到:
還有 怎麼不試試看直接選成NAT模式 這樣就根本不用去選USB無線網卡了

OLG判斷多開與否通常是看IP,所以NAT恐怕不一定可以work,不過用bridge mode應該可以work吧偷笑....BTW,鵝倒是第一次看到有人說2GB RAM跑XP+VPC2007就可以跑的很順的(尤其guest是拿來跑吃VGA的AP的OrzOrz)....

4
mrpan
iT邦新手 1 級 ‧ 2012-06-11 08:48:15

請服用 SSD
虛擬機的硬碟影像檔請放在 SSD 上
搞定!

4
louis1w
iT邦新手 3 級 ‧ 2012-06-11 11:10:51

====>但我要使用usb無線網絡的關係.....
線上遊戲 網路十分重要 改有線網卡 先

CalvinKuo iT邦大師 7 級 ‧ 2012-06-11 13:26:18 檢舉

無線網路的延遲本來就比較大,加上訊號與流量問題,可能會Lag。
所連AP與網路是不是只有版主使用還是有跑P2P軟體。

10
hector958
iT邦研究生 2 級 ‧ 2012-06-11 15:07:37

BIOS中INTEL-VT開了嗎?
這個要開喔。

shuan0114 iT邦好手 1 級 ‧ 2012-06-12 08:42:04 檢舉

我也覺得...搞不好是 VMWare tools沒裝!! 是否滑鼠可以輕鬆拖曳到Host主機畫面,而不需要按ctrl + alt +insert鍵才可以跳去guest主機?需要按三個鍵才會跳脫guest主機的話,那表示您的虛擬機沒安裝VMWare tools!!

我要發表回答

立即登入回答