iT邦幫忙

1

[Exchange]Exchange 2003升級2010狀況,2010的User無法收到來自外部與2003的信件

各位先進大家好,
最近公司在做Exchange 2003升級到2010,
目前是處於已將2010安裝完成,
已與2003做連結的共存階段,
準備要開始搬移舊信箱到2010。
不過在搬移前先測試了一下新伺服器User的收發測試時,
碰到了個大麻煩,
以下為基本狀況說明,
還請各位先進大大能夠不吝指點。

環境說明:
Server:
中華數位SPAM(簡稱SPAM)
Exchange 2003(簡稱2K3或者MS)、2010(簡稱2K10或者Mail)

運作方式:
1.對外收發信皆透過SPAM。

2K3、2K10皆有設定SMTP連接器指向SPAM,之前只有設2K3時,其實就已經可以Work了,只不過測測也幫2K10設定。

SPAM已將新伺服器寫入,設定為先傳送給2K3,如無回應轉給2K10,但是目前看起來,2K3都有收下來,只不過無法從2K3丟往2K10。

2.因為這問題研究了很久,經過多重檢驗測試,
已經將原本安裝2K10時所建立的MS-Mail與Mail-MS連接器移除,
並重新用指令重建(example.com.tw為代稱,實際執行時為公司網域無誤)
"New-RoutingGroupConnector -Name "MS2Mail" -SourceTransportServers "ms.example.com.tw" -TargetTransportServers "mail.example.com.tw" -Cost 1 -Bidirectional $true -PublicFolderReferralsEnabled $true"

從2003 Exchange 管理員可以看到連接器已建立。

3.Exchange2K3上的防ROOP機碼SuppressStateChanges已建立並重啟服務。

測試帳號說明:
mis: 原本在2K3上的帳號,伺服器安裝完之後,搬移到2K10的舊帳號。
test: 直接在2K10上新增信箱的帳號。

問題狀況:
1.目前2K3上的帳號一切運作正常,可收可發,唯一無法寄送的目的地,就是2K10上的帳號。
2.2K10上的兩個帳號,皆無法收到任何信件,包含外部與2K3。
3.2K10的mis,目前是完全無法寄出及收到任何信件。
4.2K10的test,寄出的信件,外部跟2K3上的帳號都收的到。

觀察到的跡象
1.經觀察,所有寄往2K10的信件,會先進到2K3,再透過路由群組連接器”MS2MAIL”傳送到2K10,但是信都會卡在佇列裡。

2.公用資料夾的部分,有可能也受到影響。
2K3中已經有若干公用資料夾,但是在2K10的公用資料夾管理員中,預設公用資料夾內是空白的,觀察各升級教學在講這部分的時候,理論上應該會看到2K3的公用資料夾才是,然後再將2K10加入複寫。

以上為狀況描述。
這個問題算是爬了不少文,不過大部分的先進們都是用重建連接器來解決,不過也是有碰到沒有解決的案例,在此想向各位先進大大們求救,看看能否找到癥結所在。

感激不盡

1 個回答

0
raytracy
iT邦大神 1 級 ‧ 2016-01-20 14:32:39
最佳解答

你的 EXG 2010 上面的憑證是怎麼申請出來的?

twg9999 iT邦新手 4 級 ‧ 2016-01-20 19:05:09 檢舉

Ray前輩您好
憑證伺服器為網域中的其中一台DC,
建立企業根憑證伺服器,
於2K10中建立憑證需求之後,
在透過網頁方式向企業根憑證申請網頁伺服器範本的Base64編碼憑證,
再匯回2K10中,
最後在將IMAP POP IIS三個服務指派給該憑證。
2K3則沒有申請憑證。
有關憑證的部分應該是只做了這些,
不知道是否有所遺漏?
敬請前輩指點迷津,感激不盡。

我要發表回答

立即登入回答