iT邦幫忙

0

Help! Firebase 安裝後跳 error ,指示缺少套件

這幾天第一次接觸 iOS 的資料庫插件 Firebase ,不過按照指示完成安裝之後,要在 xcode 寫到一半的 APP ,卻一直跳錯誤。

(PS: 安裝步驟中的 pod 文件添加 'Firebase\Core' ,以及到 AppDelegate 中加 configure() 這兩個步驟都已經完成。目前 APP 也還只在初階的 UI 設計階段。還沒有寫入任何資料到 Firebase ,所以應該不是語法問題

clang: error: linker command failed with exit code 1 (use -v to see invocation)

https://ithelp.ithome.com.tw/upload/images/20180111/20107694lXTnckfS1Y.png

已經在這個 error 卡一整天了,嚴重影響進度啊 QQ

還請有經驗的大家給點建議吧

看更多先前的討論...收起先前的討論...
有沒有用 command + b先build一次?
還有,如果同時開了其他的xcode專案或是playground,也會有這種情況……
ellstang iT邦新手 5 級 ‧ 2018-01-11 16:52:57 檢舉
我試試看,感恩!
ellstang iT邦新手 5 級 ‧ 2018-01-11 16:54:19 檢舉
還是不行QQ
你原先有用過cocoapods嗎?
ellstang iT邦新手 5 級 ‧ 2018-01-11 17:21:32 檢舉
不算有... 我是初學 Swift 而已
你裝了cocoapods之後該不會還是用.xcodeproj來開檔案?
使用cocoapods的話,要改用.xcworkspace來開檔案。

尚未有邦友回答

立即登入回答