iT邦幫忙

0

CentOS 5 無法安裝套件 出現錯誤 cpio:不當的魔法數字

安裝libldap rpm檔
rpm -ivh libldap-2_4-2-32bit-2.4.41-11.1.x86_64.rpm --nodeps --force
會出現
錯誤: 解壓保存檔失敗 : cpio:不當的魔法數字
求解

2 個回答

0
fuzzylee1688
iT邦新手 4 級 ‧ 2018-05-15 14:42:42

建議先昇級到高版本OS,會少掉很多無畏的安裝測試.

ken040714 iT邦新手 5 級 ‧ 2018-05-15 15:05:11 檢舉

阿..目前不敢動OS..這台是公司架mailserver服務的

0
kendias
iT邦新手 5 級 ‧ 2018-05-15 14:59:45

你要在centos中5的版本安裝libldap我是不反對

但是你所下載的版本應該是非5版本專用的

請參考
https://pkgs.org/download/libldap-2.4.so.2

https://centos.pkgs.org/5/centos-x86_64/openldap-2.3.43-28.el5_10.x86_64.rpm.html

我要發表回答

立即登入回答