iT邦幫忙

0

google app engine有支援python3嗎?

https://ithelp.ithome.com.tw/upload/images/20180823/201098069GGDsoAN8S.jpg
想請問一下目前google app engine有支援到python3嗎?
之前寫python27可以使用,但寫python36就出現此錯誤
想請問是否有官方文件可以參考
不好意思還是新手,希望有高手能解答

1 個回答

0
黃彥儒
iT邦高手 1 級 ‧ 2018-08-24 01:15:18
最佳解答
看更多先前的回應...收起先前的回應...

感謝,但是當我輸入進去時,還是會有錯誤https://ithelp.ithome.com.tw/upload/images/20180824/20109806KjFvwq7mhP.jpg

一樣的錯誤訊息
ERROR: (gcloud.app.deploy) An error occurred while parsing file: [/home/g404412697/sample-app/app.yaml]
libraries entries are only supported by the "python27" runtime
in "/home/g404412697/sample-app/app.yaml", line 17, column 1
是不是哪裡沒設定到呢?

黃彥儒 iT邦高手 1 級 ‧ 2018-08-24 12:51:06 檢舉

你為何不是用requirements.txt 來管理你的環境相依性?

我是參考<<雲端網頁程式設計Google App Engine使用Python>>這本書,邊看邊操作,只是裡面似乎沒有提到您說的部份,我對這塊也是剛入門,可以請教一下如何設定嗎?感激不盡

黃彥儒 iT邦高手 1 級 ‧ 2018-08-24 20:49:43 檢舉

我幫你翻譯錯誤好了,
libraries僅支持於python27執行環境
所以要用Python3不能使用它,正確用法請看Google官方文檔相依性章節
然後書太舊就放棄它吧,盡信書,不如無書,尤其是老舊的資訊類書籍
然後Python3還不向下相容= =

黃彥儒 iT邦高手 1 級 ‧ 2018-08-24 20:50:58 檢舉

APP Engine我有用過,但是我覺得它好貴...
最近Cloud Function也支援Python了,費用應該會便宜些

了解,我會再往cloud function研究看看,謝謝解惑

我要發表回答

立即登入回答